Type: New Feature
Resolution: Won't Fix
Affects Version/s: None
Fix Version/s: None
'exclusions' is misnamed - it should be 'leaveAsIs' or somesuch.
I want to totally exclude some packages or classes from the resulting jar. As in leave them out, or kill them, or don't have them at all in the resulting jar. Neither as their original class name nor their potential new class name.
Perforce has an 'obliterate' concept, given exclude is already used in shade, maybe obliterate is the new element for this essential feature.
|Workflow||jira [ 12963646 ]||Default workflow, editable Closed status [ 12999397 ]|
|Project Import||Mon Apr 06 01:14:06 UTC 2015 [ 1428282846586 ]|
|Workflow||jira [ 12725876 ]||Default workflow, editable Closed status [ 12764131 ]|
|Project Import||Sun Apr 05 12:26:34 UTC 2015 [ 1428236794734 ]|
|Field||Original Value||New Value|
|Resolution||Won't Fix [ 2 ]|
|Status||Open [ 1 ]||Closed [ 6 ]|
|Assignee||Benjamin Bentmann [ bentmann ]|