Uploaded image for project: 'Maven Shade Plugin'
  1. Maven Shade Plugin
  2. MSHADE-255

IllegalArgumentException on relocating class

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Duplicate
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.1.0
    • Labels:
      None
    • Environment:

      Description

                      <executions>
                                          <execution>
                                                  <phase>package</phase>
                                                  <goals>
                                                          <goal>shade</goal>
                                                  </goals>
                                                  <!---->
                                                  <configuration>
                                                          <relocations>
                                                                  <relocation>
                                                                          <pattern>org.jdom</pattern>
                                                                          <shadedPattern>my.company.shaded.org.jdom</shadedPattern>
                                                                  </relocation>
                                                          </relocations>
                                                  </configuration>
                                                  <!---->
                                          </execution>
                                  </executions>
      
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-shade-plugin:3.0.0:shade (default) on project spark-uberjar: Error creating shaded jar: null: IllegalArgumentException -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-shade-plugin:3.0.0:shade (default) on project spark-uberjar: Error creating shaded jar: null
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
      	at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
      	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
      	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:498)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Error creating shaded jar: null
      	at org.apache.maven.plugins.shade.mojo.ShadeMojo.execute(ShadeMojo.java:546)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
      	... 20 more
      Caused by: java.lang.IllegalArgumentException
      	at org.objectweb.asm.ClassReader.<init>(Unknown Source)
      	at org.objectweb.asm.ClassReader.<init>(Unknown Source)
      	at org.objectweb.asm.ClassReader.<init>(Unknown Source)
      	at org.apache.maven.plugins.shade.DefaultShader.addRemappedClass(DefaultShader.java:418)
      	at org.apache.maven.plugins.shade.DefaultShader.shadeSingleJar(DefaultShader.java:220)
      	at org.apache.maven.plugins.shade.DefaultShader.shadeJars(DefaultShader.java:181)
      	at org.apache.maven.plugins.shade.DefaultShader.shade(DefaultShader.java:104)
      	at org.apache.maven.plugins.shade.mojo.ShadeMojo.execute(ShadeMojo.java:442)
      	... 22 more
      

        Issue Links

          Activity

          rfscholte Robert Scholte added a comment -

          Should be fixed with MSHADE-258


            People

            • Assignee:
              rfscholte Robert Scholte
              Reporter:
              eliuser2 eliuser2
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development