Uploaded image for project: 'Archiva'
  1. Archiva
  2. MRM-799

Better handling of artifacts with missing poms

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.2
    • Fix Version/s: 1.2
    • Component/s: None
    • Labels:
      None

      Description

      When there is an artifact with no pom in the repository, Archiva displays the artifact and version in 'Browse Repository' but if you
      click on the version, you get:

      Error Occurred

      • Unable to find project model for [groupId:artifactId:version]

      For example, if I delete the pom and checksums for asm:asm:3.0, [and scan and update] then I get:

      http://localhost:8080/archiva/browse/asm/asm
      Browse Repository
      [top] / asm / asm
      Versions
      3.0/

      http://localhost:8080/archiva/browse/asm/asm/3.0
      Error Occurred
      Unable to find project model for [asm:asm:3.0].

        Attachments

        1. MRM-799.patch
          5 kB
          Jevica Arianne B. Zurbano
        2. mrm-799-unit-test.patch
          1 kB
          Jevica Arianne B. Zurbano

          Issue Links

            Activity

              People

              • Assignee:
                james.w.dumay james.w.dumay
                Reporter:
                wsmoak Wendy Smoak
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: