Uploaded image for project: 'Archiva'
  1. Archiva
  2. MRM-631

network proxy is always used when defined

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.1.1
    • Component/s: remote proxy
    • Labels:
      None
    • Environment:
      Linux and Windows with JRE 1.5

      Description

      I've installed Archiva 1.0 as a Maven proxy repository for internet and corporate repositories.
      I've added the remote Internet Repositories, the network proxy and the proxy connectors.

      It works well for the internet repositories but when Archiva tries to connect to the corporate repository in the same subnetwork, Archiva uses
      the network proxy despite the proxy connector is set to Direct Connection.

      If no proxy connectors is defined, Archiva didn't try to get data form the corporate repository.

      If no network proxy is defined, Archiva can contact the corporate repository but not the Internet ones.

      I've done a test with network capture (wireshark ex ethereal) to confirm the network proxy defined is used. And the result confirm my opinion, the proxy is used.

      I attach the archiva.xml configuration file in order to check it.
      The corporate repository is localrepo and is available in http form the archiva server using lynx, wget and telnet.

      Thanks for your help

        Attachments

        1. archiva.xml
          5 kB
          Jacques REYNARD

          Activity

            People

            • Assignee:
              brettporter Brett Porter
              Reporter:
              jreynard Jacques REYNARD
            • Votes:
              6 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: