Archiva
  1. Archiva
  2. MRM-1396

Purge task problem : Not enough parts to the path

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.3.1
    • Fix Version/s: 1.3.3
    • Component/s: None
    • Labels:
      None

      Description

      I keep on having these logs :
      I'm using archiva 1.3.1.
      I thought this was fixed in MRM-1151, but I still get this :

      2010-07-20 14:00:36,868 [pool-2-thread-1] INFO org.apache.maven.archiva.scheduled.executors.ArchivaRepositoryScanningTaskExecutor - Executing task from queue with job name: RepositoryTask [repositoryId=sofaxis-snapshot, resourceFile=null, scanAll=false, updateRelatedArtifacts=false]
      2010-07-20 14:00:36,868 [pool-2-thread-1] INFO org.apache.maven.archiva.repository.scanner.RepositoryScannerInstance - Walk Started: [sofaxis-snapshot] D:\maven_archiva_data\data\repositories\sofaxis-snapshot
      2010-07-20 14:00:36,868 [pool-2-thread-1] ERROR org.apache.maven.archiva.repository.scanner.functors.ConsumerProcessFileClosure - Consumer [repository-purge] had an error when processing file [D:\maven_archiva_data\data\repositories\sofaxis-snapshot\.index\nexus-maven-repository-index.zip]: Not enough parts to the path [.index\nexus-maven-repository-index.zip] to construct an ArchivaArtifact from. (Requires at least 4 parts)
      org.apache.maven.archiva.consumers.ConsumerException: Not enough parts to the path [.index\nexus-maven-repository-index.zip] to construct an ArchivaArtifact from. (Requires at least 4 parts)
      at org.apache.maven.archiva.consumers.core.repository.RepositoryPurgeConsumer.processFile(RepositoryPurgeConsumer.java:174)
      at org.apache.maven.archiva.repository.scanner.functors.ConsumerProcessFileClosure.execute(ConsumerProcessFileClosure.java:50)
      at org.apache.commons.collections.functors.IfClosure.execute(IfClosure.java:117)
      at org.apache.commons.collections.CollectionUtils.forAllDo(CollectionUtils.java:388)
      at org.apache.maven.archiva.repository.scanner.RepositoryScannerInstance.directoryWalkStep(RepositoryScannerInstance.java:137)
      at org.codehaus.plexus.util.DirectoryWalker.fireStep(DirectoryWalker.java:174)
      at org.codehaus.plexus.util.DirectoryWalker.scanDir(DirectoryWalker.java:392)
      at org.codehaus.plexus.util.DirectoryWalker.scanDir(DirectoryWalker.java:386)
      at org.codehaus.plexus.util.DirectoryWalker.scan(DirectoryWalker.java:345)
      at org.apache.maven.archiva.repository.scanner.DefaultRepositoryScanner.scan(DefaultRepositoryScanner.java:117)
      at org.apache.maven.archiva.repository.scanner.DefaultRepositoryScanner.scan(DefaultRepositoryScanner.java:61)
      at org.apache.maven.archiva.scheduled.executors.ArchivaRepositoryScanningTaskExecutor.executeTask(ArchivaRepositoryScanningTaskExecutor.java:144)
      at org.codehaus.plexus.taskqueue.execution.ThreadedTaskQueueExecutor$ExecutorRunnable$1.run(ThreadedTaskQueueExecutor.java:116)
      at edu.emory.mathcs.backport.java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:442)
      at edu.emory.mathcs.backport.java.util.concurrent.FutureTask.run(FutureTask.java:176)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:987)
      at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:528)
      at java.lang.Thread.run(Thread.java:595)
      Caused by: org.apache.maven.archiva.consumers.core.repository.RepositoryPurgeException: Not enough parts to the path [.index\nexus-maven-repository-index.zip] to construct an ArchivaArtifact from. (Requires at least 4 parts)
      at org.apache.maven.archiva.consumers.core.repository.CleanupReleasedSnapshotsRepositoryPurge.process(CleanupReleasedSnapshotsRepositoryPurge.java:194)
      at org.apache.maven.archiva.consumers.core.repository.RepositoryPurgeConsumer.processFile(RepositoryPurgeConsumer.java:167)
      ... 17 more
      Caused by: org.apache.maven.archiva.repository.layout.LayoutException: Not enough parts to the path [.index\nexus-maven-repository-index.zip] to construct an ArchivaArtifact from. (Requires at least 4 parts)
      at org.apache.maven.archiva.repository.content.DefaultPathParser.toArtifactReference(DefaultPathParser.java:65)
      at org.apache.maven.archiva.repository.content.AbstractDefaultRepositoryContent.toArtifactReference(AbstractDefaultRepositoryContent.java:54)
      at org.apache.maven.archiva.repository.content.ManagedDefaultRepositoryContent.toArtifactReference(ManagedDefaultRepositoryContent.java:340)
      at org.apache.maven.archiva.consumers.core.repository.CleanupReleasedSnapshotsRepositoryPurge.process(CleanupReleasedSnapshotsRepositoryPurge.java:103)
      ... 18 more

      1. archiva.zip
        7 kB
        Dominique Jean-Prost

        Issue Links

          Activity

          Dominique Jean-Prost created issue -
          Brett Porter added a comment -

          we'll check, as it seems identical. Maybe this is a problem on windows?

          Brett Porter made changes -
          Field Original Value New Value
          Fix Version/s 1.3.2 [ 16673 ]
          Maria Odea Ching made changes -
          Fix Version/s 1.3.2 [ 16673 ]
          Fix Version/s 1.3.3 [ 16951 ]
          Maria Odea Ching made changes -
          Assignee Maria Odea Ching [ oching ]
          Maria Odea Ching added a comment -

          I cannot reproduce this issue in 1.3.2. I tried both in Windows and Linux, but I didn't get the above error when the repository purge consumer was executed during the repo scan.

          Maria Odea Ching added a comment -

          I also couldn't reproduce this in 1.3.1.

          Dominique, were you using the standalone jetty bundle or did you deploy the Archiva war file to an app server?

          Dominique Jean-Prost added a comment -

          I'm using the standalone jetty bundle. Is there log files I could provide to you to help ?
          I run archiva on windows.

          Maria Odea Ching added a comment -

          Yes, it might help to provide the log files Can you attach the archiva.log file where the above error occurred?

          Thanks!

          Dominique Jean-Prost added a comment -

          Log file with stacktrace inside.

          Dominique Jean-Prost made changes -
          Attachment archiva.zip [ 52647 ]
          Brett Porter added a comment -

          fixed in the same way as the other purge consumers - by ignoring the exception (as purging non-artifacts makes no sense anyway)

          Brett Porter made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Assignee Maria Odea Ching [ oching ] Brett Porter [ brettporter ]
          J.D. Montgomery made changes -
          Link This issue is related to MRM-1602 [ MRM-1602 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 08:30:08 UTC 2015 [ 1428222608952 ]
          Mark Thomas made changes -
          Workflow jira [ 12708209 ] Default workflow, editable Closed status [ 12737657 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 21:01:51 UTC 2015 [ 1428267711911 ]
          Mark Thomas made changes -
          Workflow jira [ 12945757 ] Default workflow, editable Closed status [ 12983025 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          147d 12h 6m 1 Brett Porter 14/Dec/10 19:20

            People

            • Assignee:
              Brett Porter
              Reporter:
              Dominique Jean-Prost
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development