Uploaded image for project: 'Maven Release Plugin'
  1. Maven Release Plugin
  2. MRELEASE-742

Regression in 2.2.2 related to maven-gpg-plugin

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 2.2.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      OS X 10.6, Maven 3.0.3, maven-gpg-plugin 1.4

      Description

      After updating to Release Plugin 2.2.2 gpg plugin fails with error:

      "Cannot obtain passphrase in batch mode"

      Which is thrown (see http://maven.apache.org/plugins/maven-gpg-plugin/xref/org/apache/maven/plugin/gpg/AbstractGpgMojo.html) when the passphrase has not been set and the use agent parameter is
      false. The passphrase is set in my settings.xml and the useAgent has the default false value.

      Downgrading to 2.2.1 fixes the problem and the built artifacts are correctly signed.

      An example POM project can be found at:

      http://code.google.com/p/derquinse-commons/source/browse/trunk/derquinse-pom/pom.xml

        Attachments

          Activity

            People

            • Assignee:
              rfscholte Robert Scholte
              Reporter:
              andresrc Andres Rodriguez
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: