Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Incomplete
    • Affects Version/s: 2.2, 2.2.1
    • Fix Version/s: None
    • Component/s: perform
    • Labels:
      None
    • Environment:
      accurev scm provider

      Description

      During perform, the fix for MRELEASE-457 changes the checkout directory by appending the checkout path, later the release manager appends it again in determineWorkingDirectory(). As a result maven cannot find the checked out project.
      Please see attached log file with -X output, specifically line 1541 that shows the correct project path, however, when it comes to running the deploy command, it appends project path again as indicated by line 1553.

      1. output.txt
        108 kB
        Vadim Tsing

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        472d 23h 49m 1 Robert Scholte 08/Dec/12 13:33
        Mark Thomas made changes -
        Workflow jira [ 12962142 ] Default workflow, editable Closed status [ 12999722 ]
        Mark Thomas made changes -
        Project Import Mon Apr 06 00:52:26 UTC 2015 [ 1428281546237 ]
        Mark Thomas made changes -
        Workflow jira [ 12724518 ] Default workflow, editable Closed status [ 12763648 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 12:15:05 UTC 2015 [ 1428236105845 ]
        Robert Scholte made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Incomplete [ 4 ]
        Robert Scholte added a comment -

        I see no reply on Marks question, so I'll close this as incomplete, hoping it's indeed a duplicate.

        Mark Struberg added a comment -

        This could be a duplicate of MRELEASE-727 , wdyt?

        Robert Scholte made changes -
        Field Original Value New Value
        Description During perform, the fix for MRELEASE-457 changes the checkout directory by appending the checkout path, later the release manager appends it again in determineWorkingDirectory(). As a result maven cannot find the checked out project.
        Please see attached log file with -X output, specifically line 1541 that shows the correct project path, however, when it comes to running the deploy command, it appends project path again as indicated by line 1553.
        During perform, the fix for MRELEASE-457 changes the checkout directory by appending the checkout path, later the release manager appends it again in {{determineWorkingDirectory()}}. As a result maven cannot find the checked out project.
        Please see attached log file with {{-X}} output, specifically line 1541 that shows the correct project path, however, when it comes to running the deploy command, it appends project path again as indicated by line 1553.
        Affects Version/s 2.2 [ 16778 ]
        Andrey Taranov added a comment -

        Here is the log for version 2.2 release goal.

        Notice the second warning:

        Base directory is a file. Using base directory as POM location.

        This was not present in version 2.1.

        Also notice the error message:

        Working directory "C:\dev\spikes-local\mvnrelease-flat\parent\target\checkout\parent\parent" does not exist!

        The last directory is duplicated!

        C:\dev\spikes-local\mvnrelease-flat\parent>mvn release:perform -Dmaven.scm.provider.cvs.implementation=cvs_native -DcommitByProject=true
        [INFO] Scanning for projects...
        [INFO] ------------------------------------------------------------------------
        [INFO] Reactor Build Order:
        [INFO]
        [INFO] parent
        [INFO] first-jar
        [INFO] second-jar
        [INFO]
        [INFO] ------------------------------------------------------------------------
        [INFO] Building parent 1.11-SNAPSHOT
        [INFO] ------------------------------------------------------------------------
        [INFO]
        [INFO] --- maven-release-plugin:2.2:perform (default-cli) @ parent ---
        [INFO] Checking out the project to perform the release ...
        [INFO] Executing: cmd.exe /X /C "cvs -z3 -f -d :local:d:\cvsroot -q checkout -r parent-1_10-SNAPSHOT -d checkout mvnrelease-flat"
        [INFO] Working directory: C:\dev\spikes-local\mvnrelease-flat\parent\target
        [INFO] Invoking perform goals in directory C:\dev\spikes-local\mvnrelease-flat\parent\target\checkout\parent
        [INFO] Executing goals 'deploy'...
        [WARNING] Base directory is a file. Using base directory as POM location.
        [WARNING] Maven will be executed in interactive mode, but no input stream has been configured for this MavenInvoker instance.
        [INFO] ------------------------------------------------------------------------
        [INFO] Reactor Summary:
        [INFO]
        [INFO] parent ............................................ FAILURE [2.300s]
        [INFO] first-jar ......................................... SKIPPED
        [INFO] second-jar ........................................ SKIPPED
        [INFO] ------------------------------------------------------------------------
        [INFO] BUILD FAILURE
        [INFO] ------------------------------------------------------------------------
        [INFO] Total time: 2.572s
        [INFO] Finished at: Sat May 05 22:59:16 GMT+04:00 2012
        [INFO] Final Memory: 5M/15M
        [INFO] ------------------------------------------------------------------------
        [ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.2:perform (default-cli) on project parent: Error executing Maven. Working directory "C:\dev\spikes-local\mvnrelease-flat\parent\target\checkout\parent\parent" does not exist! -> [Help 1]
        [ERROR]
        [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
        [ERROR] Re-run Maven using the -X switch to enable full debug logging.
        [ERROR]
        [ERROR] For more information about the errors and possible solutions, please read the following articles:
        [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
        
        Andrey Taranov added a comment -

        Here is a log fragment from version 2.1 release goal:

        C:\dev\spikes-local\mvnrelease-flat\parent>mvn release:perform -Dmaven.scm.provider.cvs.implementation=cvs_native -DcommitByProject=true
        [INFO] Scanning for projects...
        [INFO] ------------------------------------------------------------------------
        [INFO] Reactor Build Order:
        [INFO]
        [INFO] parent
        [INFO] first-jar
        [INFO] second-jar
        [INFO]
        [INFO] ------------------------------------------------------------------------
        [INFO] Building parent 1.10-SNAPSHOT
        [INFO] ------------------------------------------------------------------------
        [INFO]
        [INFO] --- maven-release-plugin:2.1:perform (default-cli) @ parent ---
        [INFO] Checking out the project to perform the release ...
        [INFO] Executing: cmd.exe /X /C "cvs -z3 -f -d :local:d:\cvsroot -q checkout -r parent-1_9 -d checkout mvnrelease-flat"
        [INFO] Working directory: C:\dev\spikes-local\mvnrelease-flat\parent\target
        [INFO] Executing goals 'deploy'...
        
        Andrey Taranov added a comment -

        So I'm sequentially trying all versions:

        • maven-release-plugin:2.0 works OK
        • maven-release-plugin:2.1 works OK
        • maven-release-plugin:2.2 doesn't work
        Andrey Taranov added a comment -

        I'm currently using Maven 3.0.3, so I assume the problem is entirely with maven-release-plugin.

        I will try to reproduce with different versions beetween 2.0 and 2.2.2 and post the logs here. I will also upload a minimal test project I use.

        Robert Scholte added a comment -

        Based on only the output above it is not possible to reproduce this issue. According to the logging the base directory is called test-project-1 (I think), but this seems to be a file and not a directory. I still think we have to find the real cause around here.
        Andrey, it would be nice if you could figure out with which version this bug was introduced (the gap between 2.0 and 2.2.2, if you have tried this version, is huge).
        Also: Is this also an issue for Maven3?

        Andrey Taranov added a comment -

        I'm having exact same problem described by Vadim. We use CVS so the fixes in MRELEASE-457 are irrelevant.

        Have configured the parent POM to use maven-release-plugin:2.0 and the problem was solved.

        Vadim Tsing added a comment -
        Apache Maven 2.2.1 (r801777; 2009-08-06 15:16:01-0400)
        Java version: 1.6.0_29
        Java home: C:\Java\jdk1.6.0_29\jre
        Default locale: en_US, platform encoding: Cp1252
        OS name: "windows 7" version: "6.1" arch: "x86" Family: "windows"
        
        Robert Scholte added a comment -

        [WARNING] Base directory is a file. Using base directory as POM location.
        [DEBUG] Specified POM file is not named 'pom.xml'. Using the '-f' command-line option to accommodate non-standard filename...
        [DEBUG] Executing: cmd.exe /X /C "C:\java\apache-maven-2.2.1\bin\mvn.bat -X -D maven.repo.local=C:\Users\vadim\.m2\repository -f test-project-1 -D performRelease=true -P artifactory deploy"

        These lines interest me. Do you have any clue why base directory is a file on not a directory? This is probably the root of the problem.
        Could you attach your environment? (result of mvn -v

        Vadim Tsing created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Vadim Tsing
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development