Maven Release Plugin
  1. Maven Release Plugin
  2. MRELEASE-259

Provide a configuration settings for default tag/label to use when releasing

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: prepare
    • Labels:
      None

      Description

      Currently the default tag/label proposed is $

      {artifactId}

      -$

      {version}

      However i would like to only use the version, like this: ${version}

      And maybe others would like to use $

      {project.name$}

      _$

      {version}

      or something else.

      This could easily be set via the plugin configuration.

      I may provide a patch myself, when i have some more free time.

        Issue Links

          Activity

          Wouter Hermeling created issue -
          Arnaud HERITIER made changes -
          Field Original Value New Value
          Component/s prepare [ 13615 ]
          Wim Deblauwe made changes -
          Link This issue relates to MRELEASE-159 [ MRELEASE-159 ]
          Stephen Connolly added a comment -

          Closing as duplicate of MRELEASE-159

          stephenconnolly made changes -
          Resolution Duplicate [ 3 ]
          Status Open [ 1 ] Closed [ 6 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 12:15:05 UTC 2015 [ 1428236105845 ]
          Mark Thomas made changes -
          Workflow jira [ 12724082 ] Default workflow, editable Closed status [ 12763295 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 00:52:26 UTC 2015 [ 1428281546237 ]
          Mark Thomas made changes -
          Workflow jira [ 12961862 ] Default workflow, editable Closed status [ 12998756 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          1452d 1h 50m 1 stephenconnolly 24/Jun/11 08:17

            People

            • Assignee:
              Unassigned
              Reporter:
              Wouter Hermeling
            • Votes:
              5 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development