Uploaded image for project: 'Maven POMs'
  1. Maven POMs
  2. MPOM-186

Upgrade several plugins to most recent versions for JDK9/10 Support

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Done
    • Affects Version/s: ASF-19
    • Fix Version/s: ASF-20
    • Component/s: None
    • Labels:
      None

      Description

      • maven-clean-plugin 3.1.0
      • maven-compiler-plugin 3.7.0
      • maven-dependency-plugin 3.1.1
      • maven-invoker-plugin 3.1.0
      • maven-javadoc-plugin 3.0.1
      • maven-resources-plugin 3.1.0
      • maven-scm-publish-plugin 3.0.0
      • maven-war-plugin 3.2.2
      • maven-shade-plugin 3.1.1
      • maven-surefire/failsafe 2.22.0
      • maven-plugin-plugin 3.5.2
      • maven-project-info-reports-plugin 3.0.0

      This would imply to lift the minimum JRE torun Maven to JRE 7. This is related to plugins which are require minimum JDK 7 instead of JDK 6.

      Several projects are already upgrading different plugins to get the running with JDK9/JDK10 (for example surefire) and others as well. Furthermore security related things

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                khmarbaise Karl Heinz Marbaise
                Reporter:
                khmarbaise Karl Heinz Marbaise
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: