Uploaded image for project: 'Maven POMs'
  1. Maven POMs
  2. MPOM-185

jdk10 needs maven-surefire-plugin version 2.21.0

    Details

    • Type: Dependency upgrade
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: ASF-19
    • Fix Version/s: None
    • Component/s: maven-plugins
    • Labels:
    • Environment:

      w7, mvn 3.5.3, jdk-10.0.1

      Description

      The apache parent pom has this line

      <surefire.version>2.20.1</surefire.version>
      

      however in jdk10 maven-surefire-plugin goes NPE. 2.21.0 works.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                khmarbaise Karl Heinz Marbaise
                Reporter:
                tilman Tilman Hausherr
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: