Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Activity

      Transition Time In Source Status Execution Times Last Executer Last Execution Date
      Open Open In Progress In Progress
      33m 49s 1 Maria Odea Ching 22/Jun/06 22:52
      In Progress In Progress Open Open
      7d 6h 47m 1 Maria Odea Ching 30/Jun/06 05:40
      Open Open Closed Closed
      60d 13h 45m 1 Dennis Lundberg 29/Aug/06 19:25
      Mark Thomas made changes -
      Workflow jira [ 12960350 ] Default workflow, editable Closed status [ 12997399 ]
      Mark Thomas made changes -
      Project Import Mon Apr 06 00:25:00 UTC 2015 [ 1428279900867 ]
      Mark Thomas made changes -
      Workflow jira [ 12722777 ] Default workflow, editable Closed status [ 12756572 ]
      Mark Thomas made changes -
      Project Import Sun Apr 05 12:01:39 UTC 2015 [ 1428235299271 ]
      Dennis Lundberg made changes -
      Status Open [ 1 ] Closed [ 6 ]
      Resolution Fixed [ 1 ]
      Dennis Lundberg added a comment -

      I've read through the docs and it looks good. I just fixed a couple of typos and added formating and license where it was needed. Also fixed the last remaining docck error.

      Mike Perham added a comment -

      Fixed several of the bulletpoints. I was able to reproduce your problem with the example links but putting a leading slash in front of them didn't have any effect. They work fine when just browsing the HTML from the filesystem.

      Maria, feel free to close this issue if the docs look good to you.

      Mike Perham made changes -
      Assignee Maria Odea Ching [ oching ] Mike Perham [ mperham ]
      Mike Perham added a comment -

      I'll update the docs per Brett's comments.

      Maria Odea Ching made changes -
      Due Date 2006-07-10 00:00:00.0
      Brett Porter added a comment -

      also:

      • put generatingPmdAndCpd.html into usage.html
      • the reason the links aren't working is I use site:run. Make sure you add a leading / in front of the examples link in the site descriptor
      • look out for more goal names and things that could use <<<formatting>>>
      Brett Porter added a comment -
      • rename overview to index
      • goal links don't work
      • I don't think the example of pmd in the build section is that relevant
      • examples links don't work
      Mike Perham added a comment -

      I'm not sure if there is a review standard but I just read through the docs, made a few small changes (grammar and added FAQs) and think it looks to be in good shape.

      Maria Odea Ching made changes -
      Remaining Estimate 12h [ 43200 ] 0h [ 0 ]
      Time Spent 15h [ 54000 ]
      Maria Odea Ching logged work - 30/Jun/06 05:53
      • Time Spent:
        15h
         
        - Reviewed plugin docs
        - Added javadoc tags
        - Applied documentation standard
        - Revised and added additional docs
      Maria Odea Ching added a comment -

      Waiting for review..

      Maria Odea Ching made changes -
      Status In Progress [ 3 ] Open [ 1 ]
      Maria Odea Ching added a comment -

      The plugin already has the ff. in its documentation:

      • Most classes already have javadoc tags
      • HowTo apt

      To do:

      • Put additional javadoc tags
      • Set standard reports in the pom
      • Review existing HowTo apt for the usage apt
      • Create overview, faq, and examples apt
      Maria Odea Ching made changes -
      Field Original Value New Value
      Status Open [ 1 ] In Progress [ 3 ]
      Maria Odea Ching created issue -

        People

        • Assignee:
          Mike Perham
          Reporter:
          Maria Odea Ching
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Due:
            Created:
            Updated:
            Resolved:

            Time Tracking

            Estimated:
            Original Estimate - 12h Original Estimate - 12h
            12h
            Remaining:
            Remaining Estimate - 0h
            0h
            Logged:
            Time Spent - 15h
            15h

              Development