Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The plugin is supposed to support the <inherited> tag [1].
      However, it does not work.

      This makes it impossible to configure reports when using the Apache Parent pom 10.

      See also https://issues.apache.org/jira/browse/MPOM-32

      [1] http://maven.apache.org/guides/mini/guide-configuring-plugins.html#Using_the_inherited_Tag_In_Reporting_Plugins

        Issue Links

          Activity

          sebbasf created issue -
          Hervé Boutemy made changes -
          Field Original Value New Value
          Link This issue duplicates MNG-5151 [ MNG-5151 ]
          Hervé Boutemy added a comment - - edited

          the bug is not in the plugin but in Maven Core: see MNG-5155, fixed in Maven 3.0.4

          Hervé Boutemy made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Duplicate [ 3 ]
          Assignee Herve Boutemy [ hboutemy ]
          Hervé Boutemy made changes -
          Link This issue duplicates MNG-5151 [ MNG-5151 ]
          Hervé Boutemy made changes -
          Link This issue duplicates MNG-5155 [ MNG-5155 ]
          Sebb added a comment -

          What about Maven 2.x? Is there a fix for that?

          Sebb made changes -
          Resolution Duplicate [ 3 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Robert Scholte added a comment -

          This is not a bug of the Project Info Reports Plugin, but rather a Maven Core issue (MNG-5151), so closing it.

          Robert Scholte made changes -
          Status Reopened [ 4 ] Closed [ 6 ]
          Resolution Not A Bug [ 6 ]
          Assignee Herve Boutemy [ hboutemy ] Robert Scholte [ rfscholte ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 12:10:01 UTC 2015 [ 1428235801085 ]
          Mark Thomas made changes -
          Workflow jira [ 12723503 ] Default workflow, editable Closed status [ 12755933 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 00:45:01 UTC 2015 [ 1428281101090 ]
          Mark Thomas made changes -
          Workflow jira [ 12961139 ] Default workflow, editable Closed status [ 12997845 ]
          Mark Thomas made changes -
          Reporter SebbASF [ sebbasf ] Sebb [ sebb@apache.org ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          7d 2h 9m 1 Hervé Boutemy 15/Mar/12 20:51
          Closed Closed Reopened Reopened
          16m 27s 1 Sebb 15/Mar/12 21:07
          Reopened Reopened Closed Closed
          421d 18h 15m 1 Robert Scholte 11/May/13 16:22

            People

            • Assignee:
              Robert Scholte
              Reporter:
              Sebb
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development