Uploaded image for project: 'Maven Project Info Reports Plugin'
  1. Maven Project Info Reports Plugin
  2. MPIR-223

Dependency report introduces corruption in classpaths for other plugins

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3, 2.3.1
    • Fix Version/s: 2.4
    • Component/s: dependencies
    • Labels:
      None

      Description

      MPIR-144 shows up again per Neil Hartner comments. Creating this new issue

      ====

      This issue has reappeared in 2.3.1. I'm attaching an updated version of the zipped maven project that reproduces this issue. You can change which version of MPIR plugin to use with -Dmpir-version. For example:
      mvn clean install site:site -Dmpir-version=2.3.1

      2.1, 2.3 and 2.3.1 will fail
      2.1.1 and 2.2 will succeed

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                hboutemy Hervé Boutemy
                Reporter:
                carlos Carlos Sanchez
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: