Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      ubuntu linux maven 2.2.1

      Description

      We have our own custom packaging that does not compile java code.

      Since the 2.3 plugin we get this issue while running "mvn clean install site":

      ...
      [INFO] [site:site

      {execution: default-site}

      ]
      [INFO] Not executing cobertura:report as the cobertura data file (xxx/cobertura/cobertura.ser) could not be found
      [INFO] Parent project loaded from repository: xxx-parent:pom:8-SNAPSHOT
      [INFO] Skipped "Surefire Report" report, file "surefire-report.html" already exists for the English version.
      [INFO] Generating "Continuous Integration" report.
      [INFO] Generating "Project Summary" report.
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Error during page generation

      Embedded error: Error rendering Maven report: error while invoking generate
      basedir xxx/src/main/java does not exist
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.lifecycle.LifecycleExecutionException: Error during page generation
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:719)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:556)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:535)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:387)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:348)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:180)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
      at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:60)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.maven.plugin.MojoExecutionException: Error during page generation
      at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:123)
      at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:490)
      at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:694)
      ... 17 more
      Caused by: org.apache.maven.doxia.siterenderer.RendererException: Error rendering Maven report: error while invoking generate
      at org.apache.maven.plugins.site.ReportDocumentRenderer.renderDocument(ReportDocumentRenderer.java:171)
      at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.renderModule(DefaultSiteRenderer.java:330)
      at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.render(DefaultSiteRenderer.java:134)
      at org.apache.maven.plugins.site.SiteMojo.renderLocale(SiteMojo.java:154)
      at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:118)
      ... 19 more
      Caused by: org.apache.maven.reporting.MavenReportException: error while invoking generate
      at org.apache.maven.plugins.site.ReportDocumentRenderer.generateMultiPage(ReportDocumentRenderer.java:248)
      at org.apache.maven.plugins.site.ReportDocumentRenderer.renderDocument(ReportDocumentRenderer.java:157)
      ... 23 more
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.maven.plugins.site.ReportDocumentRenderer.generateMultiPage(ReportDocumentRenderer.java:226)
      ... 24 more
      Caused by: java.lang.IllegalStateException: basedir xxx/src/main/java does not exist
      at org.codehaus.plexus.util.DirectoryScanner.scan(DirectoryScanner.java:550)
      at org.codehaus.plexus.util.FileUtils.getFileAndDirectoryNames(FileUtils.java:1717)
      at org.codehaus.plexus.util.FileUtils.getFileNames(FileUtils.java:1645)
      at org.codehaus.plexus.util.FileUtils.getFileNames(FileUtils.java:1627)
      at org.apache.maven.report.projectinfo.ProjectSummaryReport$ProjectSummaryRenderer.isJavaProject(ProjectSummaryReport.java:290)
      at org.apache.maven.report.projectinfo.ProjectSummaryReport$ProjectSummaryRenderer.renderBody(ProjectSummaryReport.java:131)
      at org.apache.maven.reporting.AbstractMavenReportRenderer.render(AbstractMavenReportRenderer.java:79)
      at org.apache.maven.report.projectinfo.ProjectSummaryReport.executeReport(ProjectSummaryReport.java:55)
      at org.apache.maven.reporting.AbstractMavenReport.generate(AbstractMavenReport.java:190)
      ... 29 more

        Issue Links

          Activity

          Martijn Verburg added a comment -

          We also have this issue (in our case its a jdocbook project)

          Joerg Schaible added a comment -

          Same here for a cutsom plugin with an own packaging type (specialized ZIP file).

          Lukas Theussl added a comment -

          This was introduced in r1036245 for MPIR-80.

          Lukas Theussl added a comment -

          Could someone attach a test project for me?

          Martijn Verburg added a comment -

          If you get stuck for a simple example then you can try:

          svn export https://open.jira.com/svn/IKASAN/trunk/ikasaneip/ ikasaneip
          

          And then:

          cd ikasaneip/build
          vi pom.xml        # and change the version for the report plugin to 2.3
          mvn clean install # this is our build pom that everything inherits from
          

          And then:

          cd ikasaneip/documentation
          mvn clean install site
          

          I think that should replicate it.

          Lukas Theussl added a comment - - edited

          Fixed in r1049441. SNAPSHOT deployed, please test. Thanks!

          Francis De Brabandere added a comment -

          could you point me to the snapshot repo?

          Lukas Theussl added a comment -
          Francis De Brabandere added a comment -

          found it: https://repository.apache.org/content/repositories/snapshots
          I just tested the snapshot and the problem is fixed.


            People

            • Assignee:
              Lukas Theussl
              Reporter:
              Francis De Brabandere
            • Votes:
              2 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development