Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.1
    • Fix Version/s: 2.3
    • Component/s: dependencies
    • Labels:
      None
    • Environment:
      Windows xp, tomcat 5.5 server

      Description

      During 'mvn site' command on project i receive some strange errors. Their are no critical, but they are still errors.

      Console dump:

      [ERROR] Artifact: org.apache.abdera:abdera-core:jar:0.4.0-incubating has no file.
      [ERROR] Artifact: org.apache.abdera:abdera-extensions-json:jar:0.4.0-incubating has no file.
      [ERROR] Artifact: org.apache.abdera:abdera-extensions-main:jar:0.4.0-incubating has no file.
      [ERROR] Artifact: org.apache.abdera:abdera-i18n:jar:0.4.0-incubating has no file.
      [ERROR] Artifact: org.apache.abdera:abdera-parser:jar:0.4.0-incubating has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-api:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-common-schemas:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-common-utilities:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-rt-bindings-soap:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-rt-bindings-xml:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-rt-core:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-rt-databinding-jaxb:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-rt-frontend-simple:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-rt-ws-addr:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.cxf:cxf-tools-common:jar:2.2 has no file.
      [ERROR] Artifact: org.apache.geronimo.specs:geronimo-activation_1.1_spec:jar:1.0.2 has no file.
      [ERROR] Artifact: org.apache.geronimo.specs:geronimo-annotation_1.0_spec:jar:1.1.1 has no file.
      [ERROR] Artifact: org.apache.geronimo.specs:geronimo-javamail_1.4_spec:jar:1.5 has no file.
      [ERROR] Artifact: org.apache.geronimo.specs:geronimo-jaxws_2.1_spec:jar:1.0 has no file.
      [ERROR] Artifact: org.apache.geronimo.specs:geronimo-servlet_2.5_spec:jar:1.2 has no file.
      [ERROR] Artifact: org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:jar:1.0.1 has no file.
      [ERROR] Artifact: org.apache.geronimo.specs:geronimo-ws-metadata_2.0_spec:jar:1.1.2 has no file.
      [ERROR] Artifact: org.apache.neethi:neethi:jar:2.0.4 has no file.
      [ERROR] Artifact: org.apache.ws.commons.axiom:axiom-api:jar:1.2.7 has no file.
      [ERROR] Artifact: org.apache.ws.commons.axiom:axiom-impl:jar:1.2.7 has no file.
      [ERROR] Artifact: org.apache.ws.commons.schema:XmlSchema:jar:1.4.4 has no file.
      [ERROR] Artifact: org.apache.xmlbeans:xmlbeans:jar:2.3.0 has no file.
      [ERROR] Artifact: org.codehaus.jettison:jettison:jar:1.0.1 has no file.
      [ERROR] Artifact: org.codehaus.woodstox:wstx-asl:jar:3.2.6 has no file.
      [ERROR] Artifact: org.hibernate:ejb3-persistence:jar:1.0.1.GA has no file.
      [ERROR] Artifact: org.hibernate:hibernate-commons-annotations:jar:3.0.0.ga has no file.
      [ERROR] Artifact: org.mortbay.jetty:jetty:jar:6.1.15 has no file.
      [ERROR] Artifact: org.mortbay.jetty:jetty-util:jar:6.1.15 has no file.
      [ERROR] Artifact: org.slf4j:slf4j-api:jar:1.3.1 has no file.
      [ERROR] Artifact: org.slf4j:slf4j-jdk14:jar:1.3.1 has no file.
      [ERROR] Artifact: org.springframework:spring-beans:jar:2.5.5 has no file.
      [ERROR] Artifact: org.springframework:spring-context:jar:2.5.5 has no file.
      [ERROR] Artifact: org.springframework:spring-core:jar:2.5.5 has no file.
      [ERROR] Artifact: org.springframework:spring-web:jar:2.5.5 has no file.
      [ERROR] Artifact: wsdl4j:wsdl4j:jar:1.6.2 has no file.
      [ERROR] Artifact: xalan:xalan:jar:2.6.0 has no file.
      [ERROR] Artifact: xerces:xercesImpl:jar:2.6.2 has no file.
      [ERROR] Artifact: xerces:xmlParserAPIs:jar:2.6.2 has no file.
      [ERROR] Artifact: xml-apis:xml-apis:jar:1.3.02 has no file.
      [ERROR] Artifact: xml-resolver:xml-resolver:jar:1.2 has no file.
      [ERROR] Artifact: xom:xom:jar:1.0 has no file.
      [INFO] Generating "Project Team" report.
      [INFO] Generating "Project License" report.
      [INFO] Generating "Project Plugins" report.
      [INFO] Generating "Maven Surefire Report" report.
      [INFO] Generating "FindBugs Report" report.
      [INFO]   Using source root:
      [INFO]     C:\edys_workspace\edystok\target\classes
      [INFO]   Using test source root:
      [INFO]     C:\edys_workspace\edystok\target\test-classes
      [INFO]   No effort provided, using default effort.
      [INFO]   Adding Source Directory: C:\edys_workspace\edystok\src\main\java
      [INFO]   No threshold provided, using default threshold.
      [INFO]   Using FindBugs Version: 1.3.7
      [INFO]   No threshold provided, using default threshold.
      [INFO]   No threshold provided, using default threshold.
      [INFO]   Debugging is Off
      [INFO]   No bug include filter.
      [INFO]   No bug exclude filter.
      ....

      there are no other error, and build is successfull

        Issue Links

          Activity

          Damian Sinczak created issue -
          Dennis Lundberg added a comment -

          Can you please provide a full log of the output.

          At first glance it seems to have something to do with Maven Project Info Reports Plugin.

          christian-Luc Houze added a comment -

          I've got the same proble (maven-site-plugin 2.0-beta-6)

          [INFO] Generating "Dépendances" report.
          [ERROR] Artifact: libDtd.composants:DTD_codeDef_ejb:ejb:4.3 has no file.
          [ERROR] Artifact: libDtd.composants:DTD_codeDef_server:jar:4.3.0 has no file.
          [ERROR] Artifact: libDtd.composants:DTD_codeDef_shared:jar:4.3.0 has no file.
          [ERROR] Artifact: libDtd.framework.Commun:DTD_framework_server:jar:4.3.0 has no file.
          [ERROR] Artifact: libDtd.framework.Commun:DTD_framework_shared:jar:4.3.0.1 has no file.
          [ERROR] Artifact: libDtd.framework.Commun:DTD_securite_menu_ejb:ejb:4.3 has no file.
          [ERROR] Artifact: libDtd.framework.Commun:DTD_securite_menu_shared:jar:4.3.0 has no file.
          [ERROR] Artifact: libDtd.framework.Web:DTD_frameworkWeb_shared:jar:4.2.0 has no file.
          [ERROR] Artifact: libStd.jakarta.commons:commons-fileupload:jar:1.0 has no file.
          [ERROR] Artifact: libStd.jakarta.commons:commons-lang:jar:2.4 has no file.
          [ERROR] Artifact: libStd.jakarta.commons:commons-validator:jar:1.1.4 has no file.
          [ERROR] Artifact: libStd.jakarta.jstl:jaxen-full:jar:1.0.3 has no file.
          [ERROR] Artifact: libStd.jakarta.jstl:jstl:jar:1.0.3 has no file.

          [ERROR] Artifact: libStd.jakarta.jstl:standard:jar:1.0.3 has no file.
          [ERROR] Artifact: libStd.jakarta.struts:jakarta-oro:jar:1.1 has no file.
          [ERROR] Artifact: libStd.jakarta.struts:jakarta-struts:jar:1.1 has no file.
          [ERROR] Artifact: libStd.jakarta.struts:jakarta-struts-el:jar:1.1 has no file.
          [ERROR] Artifact: libStd.jakarta.struts:jakarta-struts-legacy:jar:1.1 has no file.
          [ERROR] Artifact: libStd.jakarta.struts:jdbc2_0-stdext:jar:1.1 has no file.
          [ERROR] Artifact: logkit:logkit:jar:1.0.1 has no file.
          [ERROR] Artifact: org.openqa.selenium.core:selenium-core:jar:0.8.3 has no file.
          [ERROR] Artifact: org.openqa.selenium.server:selenium-server:jar:standalone:0.9.2 has no file.
          [ERROR] Artifact: org.openqa.selenium.server:selenium-server-coreless:jar:0.9.1 has no file.

          does not seem to alter the site generation, but this suddenly appeared (cannot find yet the change what triggered this error coming out)
          Any information about what this error mean ?

          Thanks,

          Christian-Luc

          Dennis Lundberg added a comment -

          Like I said before, we need the full output of the log to be able to determine where the error is.

          Stevo Slavic added a comment -

          Just created issue on maven project info reports plugin JIRA ( MPIR-157 ). It seems to be issue in 2.1.1 version of the mentioned plugin.

          Dennis Lundberg made changes -
          Field Original Value New Value
          Key MSITE-397 MPIR-158
          Affects Version/s 2.1.1 [ 14325 ]
          Affects Version/s 2.0 [ 13362 ]
          Project Maven 2.x Site Plugin [ 11146 ] Maven 2.x Project Info Reports Plugin [ 11142 ]
          Hervé Boutemy made changes -
          Link This issue is duplicated by MPIR-157 [ MPIR-157 ]
          Hervé Boutemy made changes -
          Component/s dependencies [ 13326 ]
          Stevo Slavic added a comment -

          Can't reproduce this anymore.

          Hervé Boutemy made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]
          Ryan Connolly added a comment -

          FYI: I am seeing the exact same behaviour using project-info-reports-plugin version 2.1.2 with maven-site-plugin version 2.0-beta-7 when running goal site-deploy. Below is the m-p-i-r-p snippet i have configured in my parent POM.

          <plugin>
          <artifactId>maven-project-info-reports-plugin</artifactId>
          <version>2.1.2</version>
          <configuration>
          <dependencyDetailsEnabled>false</dependencyDetailsEnabled>
          <dependencyLocationsEnabled>false</dependencyLocationsEnabled>
          </configuration>
          </plugin>

          [18:12:56]: [ERROR] Artifact: javax.transaction:jta:jar:1.0.1B has no file.
          [18:12:56]: [ERROR] Artifact: jaxen:jaxen:jar:1.1.1 has no file.
          [18:12:56]: [ERROR] Artifact: jdom:jdom:jar:1.0 has no file.
          [18:12:56]: [ERROR] Artifact: net.sf.ehcache:ehcache:jar:1.2.3 has no file.
          [18:12:56]: [ERROR] Artifact: net.sf.ezmorph:ezmorph:jar:1.0.6 has no file.
          [18:12:56]: [ERROR] Artifact: org.hibernate:ejb3-persistence:jar:1.0.2.GA has no file.
          [18:12:56]: [ERROR] Artifact: org.hibernate:hibernate:jar:3.2.5.ga has no file.
          [18:12:56]: [ERROR] Artifact: org.hibernate:hibernate-annotations:jar:3.4.0.GA has no file.
          [18:12:56]: [ERROR] Artifact: org.hibernate:hibernate-commons-annotations:jar:3.1.0.GA has no file.
          [18:12:56]: [ERROR] Artifact: org.hibernate:hibernate-core:jar:3.3.0.SP1 has no file.
          [18:12:56]: [ERROR] Artifact: org.jdom:jdom:jar:1.1 has no file.
          [18:12:56]: [ERROR] Artifact: org.slf4j:slf4j-api:jar:1.5.6 has no file.
          [18:12:57]: [ERROR] Artifact: xalan:xalan:jar:2.6.0 has no file.
          [18:12:57]: [ERROR] Artifact: xerces:xercesImpl:jar:2.8.1 has no file.
          [18:12:57]: [ERROR] Artifact: xerces:xmlParserAPIs:jar:2.6.2 has no file.
          [18:12:57]: [ERROR] Artifact: xml-apis:xml-apis:jar:1.3.03 has no file.
          [18:12:57]: [ERROR] Artifact: xom:xom:jar:1.0 has no file.

          Stevo Slavic added a comment -

          True, it started appearing again with 2.1.2 on a very complex project, but can not reproduce it on a simple project that could be attached to the issue.

          Can not reopen the issue, maybe new one will have to be created with maybe a link to this one.

          Benjamin Bentmann made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Andrea Aime added a comment -

          I am seeing the same in my project, similar configuration, using Maven 2.1.0
          I also have the same config, having the plugin check on the internet for all those small files just makes the build take forever (high latency connection)

          Vincent Massol added a comment - - edited

          I also get this problem with 2.1.2 on the xwiki platform build (mvn clean site after checking out http://svn.xwiki.org/svnroot/xwiki/platform/trunks/). Note you'll need to add the xwik remote repo to your settings.xml to build as described at http://dev.xwiki.org/xwiki/bin/view/Community/Building#HInstallingMaven

          ...
          [INFO] ------------------------------------------------------------------------
          [INFO] Building XWiki Platform - Core - Core
          [INFO]    task-segment: [clean, site]
          [INFO] ------------------------------------------------------------------------
          [INFO] [clean:clean {execution: default-clean}]
          [INFO] Deleting directory /Users/vmassol/dev/xwiki/trunks-clean2/platform/core/xwiki-core/target
          [INFO] Preparing javadoc:javadoc
          Downloading: http://maven.xwiki.org/snapshots/org/xwiki/platform/xwiki-core-configuration-api/2.1-SNAPSHOT/xwiki-core-configuration-api-2.1-20091020.153812-107.jar
          13K downloaded  (xwiki-core-configuration-api-2.1-20091020.153812-107.jar)
          Downloading: http://maven.xwiki.org/snapshots/org/xwiki/platform/xwiki-core-xml/2.1-SNAPSHOT/xwiki-core-xml-2.1-20091020.153812-107.jar
          64K downloaded  (xwiki-core-xml-2.1-20091020.153812-107.jar)
          Downloading: http://maven.xwiki.org/snapshots/org/xwiki/platform/xwiki-core-rendering-parser-wikimodel/2.1-SNAPSHOT/xwiki-core-rendering-parser-wikimodel-2.1-20091020.153812-106.jar
          38K downloaded  (xwiki-core-rendering-parser-wikimodel-2.1-20091020.153812-106.jar)
          [INFO] [enforcer:enforce {execution: default}]
          [INFO] [site:site {execution: default-site}]
          [INFO] Unable to load parent project from a relative path: Could not find the model file '/Users/vmassol/dev/xwiki/trunks-clean2/platform/core/../pom'. for project unknown
          [INFO] Parent project loaded from repository.
          [INFO] Generating "Dependency Convergence" report.
          [INFO] Generating "Project Summary" report.
          [INFO] Generating "About" report.
          [INFO] Generating "Issue Tracking" report.
          [INFO] Generating "Source Repository" report.
          [INFO] Generating "Mailing Lists" report.
          [INFO] Generating "Dependencies" report.
          Downloading: http://maven.xwiki.org/externals/org/xwiki/platform/xwiki-core-rendering-parser-wikimodel/2.1-SNAPSHOT/xwiki-core-rendering-parser-wikimodel-2.1-20091020.153812-106.pom
          [INFO] Unable to find resource 'org.xwiki.platform:xwiki-core-rendering-parser-wikimodel:pom:2.1-SNAPSHOT' in repository xwiki-externals (http://maven.xwiki.org/externals)
          Downloading: http://maven.xwiki.org/snapshots/org/xwiki/platform/xwiki-core-rendering-parser-wikimodel/2.1-SNAPSHOT/xwiki-core-rendering-parser-wikimodel-2.1-20091020.153812-106.pom
          2K downloaded  (xwiki-core-rendering-parser-wikimodel-2.1-20091020.153812-106.pom)
          Downloading: http://maven.xwiki.org/externals/org/xwiki/platform/xwiki-core-xml/2.1-SNAPSHOT/xwiki-core-xml-2.1-20091020.153812-107.pom
          [INFO] Unable to find resource 'org.xwiki.platform:xwiki-core-xml:pom:2.1-SNAPSHOT' in repository xwiki-externals (http://maven.xwiki.org/externals)
          Downloading: http://maven.xwiki.org/snapshots/org/xwiki/platform/xwiki-core-xml/2.1-SNAPSHOT/xwiki-core-xml-2.1-20091020.153812-107.pom
          3K downloaded  (xwiki-core-xml-2.1-20091020.153812-107.pom)
          [ERROR] Artifact: org.openoffice:jurt:jar:3.0.1 has no file.
          [ERROR] Artifact: org.openoffice:ridl:jar:3.0.1 has no file.
          [ERROR] Artifact: org.openoffice:unoil:jar:3.0.1 has no file.
          [ERROR] Artifact: org.python:jython-standalone:jar:2.5.1-xwiki has no file.
          [ERROR] Artifact: org.slf4j:slf4j-api:jar:1.5.8 has no file.
          [ERROR] Artifact: org.slf4j:slf4j-log4j12:jar:1.5.8 has no file.
          [ERROR] Artifact: org.wikimodel:org.wikimodel.wem:jar:2.0.7-20091015 has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-action:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-classloader:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-component-api:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-configuration-api:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-container-api:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-container-servlet:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-properties:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-query-jpql-parser:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-refactoring:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-rendering-macro-script:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-url-api:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: org.xwiki.platform:xwiki-core-url-default:jar:2.1-SNAPSHOT has no file.
          [ERROR] Artifact: pygments:pygments:jar:1.0-xwiki-1 has no file.
          [ERROR] Artifact: uk.ac.ed.ph.snuggletex:snuggletex-core:jar:1.1.0 has no file.
          [ERROR] Artifact: uk.ac.ed.ph.snuggletex:snuggletex-jeuclid:jar:1.1.0 has no file.
          [ERROR] Artifact: velocity-tools:velocity-tools:jar:1.4 has no file.
          [ERROR] Artifact: xalan:xalan:jar:2.5.1 has no file.
          [ERROR] Artifact: xml-apis:xml-apis-ext:jar:1.3.04 has no file.
          ...
          
          Siveton Vincent added a comment -

          fixed in r1036825, snapshot deployed

          Siveton Vincent made changes -
          Assignee Vincent Siveton [ siveton ]
          Status Reopened [ 4 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Fix Version/s 2.3 [ 16664 ]
          Hervé Boutemy made changes -
          Description During 'mvn site' command on project i receive some strange errors. Their are no critical, but they are still errors.

          Console dump:

          [ERROR] Artifact: org.apache.abdera:abdera-core:jar:0.4.0-incubating has no file
          .
          [ERROR] Artifact: org.apache.abdera:abdera-extensions-json:jar:0.4.0-incubating
          has no file.
          [ERROR] Artifact: org.apache.abdera:abdera-extensions-main:jar:0.4.0-incubating
          has no file.
          [ERROR] Artifact: org.apache.abdera:abdera-i18n:jar:0.4.0-incubating has no file
          .
          [ERROR] Artifact: org.apache.abdera:abdera-parser:jar:0.4.0-incubating has no fi
          le.
          [ERROR] Artifact: org.apache.cxf:cxf-api:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-common-schemas:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-common-utilities:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-bindings-soap:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-bindings-xml:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-core:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-databinding-jaxb:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-frontend-simple:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-ws-addr:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-tools-common:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-activation_1.1_spec:jar:1.0
          .2 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-annotation_1.0_spec:jar:1.1
          .1 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-javamail_1.4_spec:jar:1.5 h
          as no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-jaxws_2.1_spec:jar:1.0 has
          no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-servlet_2.5_spec:jar:1.2 ha
          s no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:jar:1.0.1
           has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-ws-metadata_2.0_spec:jar:1.
          1.2 has no file.
          [ERROR] Artifact: org.apache.neethi:neethi:jar:2.0.4 has no file.
          [ERROR] Artifact: org.apache.ws.commons.axiom:axiom-api:jar:1.2.7 has no file.
          [ERROR] Artifact: org.apache.ws.commons.axiom:axiom-impl:jar:1.2.7 has no file.
          [ERROR] Artifact: org.apache.ws.commons.schema:XmlSchema:jar:1.4.4 has no file.
          [ERROR] Artifact: org.apache.xmlbeans:xmlbeans:jar:2.3.0 has no file.
          [ERROR] Artifact: org.codehaus.jettison:jettison:jar:1.0.1 has no file.
          [ERROR] Artifact: org.codehaus.woodstox:wstx-asl:jar:3.2.6 has no file.
          [ERROR] Artifact: org.hibernate:ejb3-persistence:jar:1.0.1.GA has no file.
          [ERROR] Artifact: org.hibernate:hibernate-commons-annotations:jar:3.0.0.ga has n
          o file.
          [ERROR] Artifact: org.mortbay.jetty:jetty:jar:6.1.15 has no file.
          [ERROR] Artifact: org.mortbay.jetty:jetty-util:jar:6.1.15 has no file.
          [ERROR] Artifact: org.slf4j:slf4j-api:jar:1.3.1 has no file.
          [ERROR] Artifact: org.slf4j:slf4j-jdk14:jar:1.3.1 has no file.
          [ERROR] Artifact: org.springframework:spring-beans:jar:2.5.5 has no file.
          [ERROR] Artifact: org.springframework:spring-context:jar:2.5.5 has no file.
          [ERROR] Artifact: org.springframework:spring-core:jar:2.5.5 has no file.
          [ERROR] Artifact: org.springframework:spring-web:jar:2.5.5 has no file.
          [ERROR] Artifact: wsdl4j:wsdl4j:jar:1.6.2 has no file.
          [ERROR] Artifact: xalan:xalan:jar:2.6.0 has no file.
          [ERROR] Artifact: xerces:xercesImpl:jar:2.6.2 has no file.
          [ERROR] Artifact: xerces:xmlParserAPIs:jar:2.6.2 has no file.
          [ERROR] Artifact: xml-apis:xml-apis:jar:1.3.02 has no file.
          [ERROR] Artifact: xml-resolver:xml-resolver:jar:1.2 has no file.
          [ERROR] Artifact: xom:xom:jar:1.0 has no file.
          [INFO] Generating "Project Team" report.
          [INFO] Generating "Project License" report.
          [INFO] Generating "Project Plugins" report.
          [INFO] Generating "Maven Surefire Report" report.
          [INFO] Generating "FindBugs Report" report.
          [INFO] Using source root:
          [INFO] C:\edys_workspace\edystok\target\classes
          [INFO] Using test source root:
          [INFO] C:\edys_workspace\edystok\target\test-classes
          [INFO] No effort provided, using default effort.
          [INFO] Adding Source Directory: C:\edys_workspace\edystok\src\main\java
          [INFO] No threshold provided, using default threshold.
          [INFO] Using FindBugs Version: 1.3.7
          [INFO] No threshold provided, using default threshold.
          [INFO] No threshold provided, using default threshold.
          [INFO] Debugging is Off
          [INFO] No bug include filter.
          [INFO] No bug exclude filter.
          ....

          there are no other error, and build is successfull
          During 'mvn site' command on project i receive some strange errors. Their are no critical, but they are still errors.

          Console dump:

          {noformat}[ERROR] Artifact: org.apache.abdera:abdera-core:jar:0.4.0-incubating has no file.
          [ERROR] Artifact: org.apache.abdera:abdera-extensions-json:jar:0.4.0-incubating has no file.
          [ERROR] Artifact: org.apache.abdera:abdera-extensions-main:jar:0.4.0-incubating has no file.
          [ERROR] Artifact: org.apache.abdera:abdera-i18n:jar:0.4.0-incubating has no file.
          [ERROR] Artifact: org.apache.abdera:abdera-parser:jar:0.4.0-incubating has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-api:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-common-schemas:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-common-utilities:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-bindings-soap:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-bindings-xml:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-core:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-databinding-jaxb:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-frontend-simple:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-rt-ws-addr:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.cxf:cxf-tools-common:jar:2.2 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-activation_1.1_spec:jar:1.0.2 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-annotation_1.0_spec:jar:1.1.1 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-javamail_1.4_spec:jar:1.5 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-jaxws_2.1_spec:jar:1.0 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-servlet_2.5_spec:jar:1.2 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-stax-api_1.0_spec:jar:1.0.1 has no file.
          [ERROR] Artifact: org.apache.geronimo.specs:geronimo-ws-metadata_2.0_spec:jar:1.1.2 has no file.
          [ERROR] Artifact: org.apache.neethi:neethi:jar:2.0.4 has no file.
          [ERROR] Artifact: org.apache.ws.commons.axiom:axiom-api:jar:1.2.7 has no file.
          [ERROR] Artifact: org.apache.ws.commons.axiom:axiom-impl:jar:1.2.7 has no file.
          [ERROR] Artifact: org.apache.ws.commons.schema:XmlSchema:jar:1.4.4 has no file.
          [ERROR] Artifact: org.apache.xmlbeans:xmlbeans:jar:2.3.0 has no file.
          [ERROR] Artifact: org.codehaus.jettison:jettison:jar:1.0.1 has no file.
          [ERROR] Artifact: org.codehaus.woodstox:wstx-asl:jar:3.2.6 has no file.
          [ERROR] Artifact: org.hibernate:ejb3-persistence:jar:1.0.1.GA has no file.
          [ERROR] Artifact: org.hibernate:hibernate-commons-annotations:jar:3.0.0.ga has no file.
          [ERROR] Artifact: org.mortbay.jetty:jetty:jar:6.1.15 has no file.
          [ERROR] Artifact: org.mortbay.jetty:jetty-util:jar:6.1.15 has no file.
          [ERROR] Artifact: org.slf4j:slf4j-api:jar:1.3.1 has no file.
          [ERROR] Artifact: org.slf4j:slf4j-jdk14:jar:1.3.1 has no file.
          [ERROR] Artifact: org.springframework:spring-beans:jar:2.5.5 has no file.
          [ERROR] Artifact: org.springframework:spring-context:jar:2.5.5 has no file.
          [ERROR] Artifact: org.springframework:spring-core:jar:2.5.5 has no file.
          [ERROR] Artifact: org.springframework:spring-web:jar:2.5.5 has no file.
          [ERROR] Artifact: wsdl4j:wsdl4j:jar:1.6.2 has no file.
          [ERROR] Artifact: xalan:xalan:jar:2.6.0 has no file.
          [ERROR] Artifact: xerces:xercesImpl:jar:2.6.2 has no file.
          [ERROR] Artifact: xerces:xmlParserAPIs:jar:2.6.2 has no file.
          [ERROR] Artifact: xml-apis:xml-apis:jar:1.3.02 has no file.
          [ERROR] Artifact: xml-resolver:xml-resolver:jar:1.2 has no file.
          [ERROR] Artifact: xom:xom:jar:1.0 has no file.
          [INFO] Generating "Project Team" report.
          [INFO] Generating "Project License" report.
          [INFO] Generating "Project Plugins" report.
          [INFO] Generating "Maven Surefire Report" report.
          [INFO] Generating "FindBugs Report" report.
          [INFO] Using source root:
          [INFO] C:\edys_workspace\edystok\target\classes
          [INFO] Using test source root:
          [INFO] C:\edys_workspace\edystok\target\test-classes
          [INFO] No effort provided, using default effort.
          [INFO] Adding Source Directory: C:\edys_workspace\edystok\src\main\java
          [INFO] No threshold provided, using default threshold.
          [INFO] Using FindBugs Version: 1.3.7
          [INFO] No threshold provided, using default threshold.
          [INFO] No threshold provided, using default threshold.
          [INFO] Debugging is Off
          [INFO] No bug include filter.
          [INFO] No bug exclude filter.
          ....{noformat}

          there are no other error, and build is successfull
          Hervé Boutemy made changes -
          Link This issue relates to MPIR-223 [ MPIR-223 ]
          ibrandt made changes -
          Link This issue is related to MPIR-251 [ MPIR-251 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 12:10:01 UTC 2015 [ 1428235801085 ]
          Mark Thomas made changes -
          Workflow jira [ 12723427 ] Default workflow, editable Closed status [ 12755994 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 00:45:01 UTC 2015 [ 1428281101090 ]
          Mark Thomas made changes -
          Workflow jira [ 12961180 ] Default workflow, editable Closed status [ 12998187 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          58d 3h 50m 1 Hervé Boutemy 28/May/09 12:37
          Closed Closed Reopened Reopened
          69d 20h 24m 1 Benjamin Bentmann 06/Aug/09 09:02
          Reopened Reopened Closed Closed
          469d 21h 47m 1 Siveton Vincent 19/Nov/10 06:50

            People

            • Assignee:
              Siveton Vincent
              Reporter:
              Damian Sinczak
            • Votes:
              8 Vote for this issue
              Watchers:
              15 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development