Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.1
    • Fix Version/s: 2.2
    • Component/s: dependencies
    • Labels:
      None

      Description

      The dependencies report takes forever and running debug i can see it's hitting the same repos over and over and bypassing my repository manager.

      1. log.log
        193 kB
        Dominique Jean-Prost
      2. MPIR-150.patch
        0.8 kB
        Philipp Berger

        Issue Links

          Activity

          Siveton Vincent added a comment -

          Do you mean an intranet repo or similar?

          Julien HENRY added a comment -

          I have the same problem.

          I have a corporate archiva mirror for central:

          <mirror>
                <id>central</id>
                <mirrorOf>central</mirrorOf>
                <name>Central Mirror</name>
                <url>http://pic-java-nce.sud.mycompany.fr:8090/archiva/repository/central</url>
          </mirror>
          

          And also 2 additional repos declared in my pom.xml:

                   <repositories>
          		<!-- Repositories Corporate  -->
          		<repository>
          			<id>mycompany.corporate.release</id>
          			<name>mycompany Corporate Release Repository</name>
          			<url>http://pic-java-nce.sud.mycompany.fr:8090/archiva/repository/mycompany.corporate.release</url>
          			<releases>
          				<enabled>true</enabled>
          			</releases>
          			<snapshots>
          				<enabled>false</enabled>
          			</snapshots>
          		</repository>
          		<repository>
          			<id>mycompany.local.release</id>
          			<name>mycompany Local Release Repository</name>
          			<url>http://pic-java-nce.sud.mycompany.fr:8090/archiva/repository/release</url>
          			<releases>
          				<enabled>true</enabled>
          			</releases>
          			<snapshots>
          				<enabled>false</enabled>
          			</snapshots>
          		</repository>
          	</repositories>
          

          Running:

          mvn org.apache.maven.plugins:maven-project-info-reports-plugin:2.1.1:dependencies -X
          

          Takes 3 minutes 37 seconds with lots of:

          [DEBUG] Checking for pre-existing User-Agent configuration.
          [DEBUG] Adding User-Agent configuration.
          http://repo1.maven.org/maven/ - Session: Opened
          http://repo1.maven.org/maven/ - Session: Disconnecting
          http://repo1.maven.org/maven/ - Session: Disconnected
          [DEBUG] Checking for pre-existing User-Agent configuration.
          [DEBUG] Adding User-Agent configuration.
          http://people.apache.org/repo/m2-incubating-repository/ - Session: Opened
          http://people.apache.org/repo/m2-incubating-repository/ - Session: Disconnecting
          http://people.apache.org/repo/m2-incubating-repository/ - Session: Disconnected
          [DEBUG] Checking for pre-existing User-Agent configuration.
          [DEBUG] Adding User-Agent configuration.
          http://repository.codehaus.org - Session: Opened
          http://repository.codehaus.org - Session: Disconnecting
          http://repository.codehaus.org - Session: Disconnected
          [DEBUG] Checking for pre-existing User-Agent configuration.
          [DEBUG] Adding User-Agent configuration.
          http://repo1.maven.org/eclipse - Session: Opened
          http://repo1.maven.org/eclipse - Session: Disconnecting
          http://repo1.maven.org/eclipse - Session: Disconnected
          [DEBUG] Checking for pre-existing User-Agent configuration.
          [DEBUG] Adding User-Agent configuration.
          http://repo1.maven.org/maven2 - Session: Opened
          http://repo1.maven.org/maven2 - Session: Disconnecting
          http://repo1.maven.org/maven2 - Session: Disconnected
          [DEBUG] Checking for pre-existing User-Agent configuration.
          [DEBUG] Adding User-Agent configuration.
          http://ws.zones.apache.org/repository2 - Session: Opened
          http://ws.zones.apache.org/repository2 - Session: Disconnecting
          http://ws.zones.apache.org/repository2 - Session: Disconnected
          

          Very blocking for me because some projects that use a lot of additional repositories have their build taking more than 1 hour instead of less than 2 minutes after disabling dependency report.

          The only workaround for my IC platform is to lock down plugin version to 2.0.1.

          If you need more debug informations, fell free to ask.

          Julien HENRY added a comment -

          Is this bug a duplicate of (now resolved) MPIR-160?

          Justin Smith added a comment -

          I am getting the same symptoms on 2.2.0 r788681... Using artifactory on the intranet here.

          marka added a comment - - edited

          We too are experiencing this issue, with Maven 2.2.1 on a new Linux build server in our environment. Our main Linux build server (same configuration as far as we can tell) does not experience the issue, nor have we seen the issue on Windows developer environments we use.

          We have an EAR build that usually takes about 47 seconds to complete on unaffected servers. When affected by this issue, the build time increases to nearly 8 minutes.

          The site goal starts normally, then we get a 3 minute and 13 second delay on one of our modules, followed by (not sure this is related):

          build	06-Oct-2009 14:27:36	[WARNING] The repository url 'https://maven-repository.dev.java.net/nonav/repository' 
          is invalid - Repository 'java.net' will be blacklisted.
          

          and then a LOT of the following messages for dozens of repositories, taking up almost another 3 minutes of the site generation for the different modules in our EAR build.

          build	06-Oct-2009 14:27:43	[DEBUG] Using Wagon implementation lightweight from default mapping for protocol http
          build	06-Oct-2009 14:27:43	[DEBUG] Checking for pre-existing User-Agent configuration.
          build	06-Oct-2009 14:27:43	[DEBUG] Adding User-Agent configuration.
          build	06-Oct-2009 14:27:43	http://repo1.maven.org/maven2 - Session: Opened  
          build	06-Oct-2009 14:27:43	http://repo1.maven.org/maven2 - Session: Disconnecting  
          build	06-Oct-2009 14:27:43	http://repo1.maven.org/maven2 - Session: Disconnected
          ...
          

          Manually setting the version of the maven-project-info-reports-plugin to version 2.0.1 works around the issue for us too.

          Our Maven install is basic with no mirrors or artifactory configurations. We are behind a corporate proxy that is configured in settings.xml.

          Lukas Laag added a comment - - edited

          The workaround consisting in locking down the plugin to version 2.0.1 only works partially for me (works for the "Dependencies" report but not for the "Project License" report)

          Philipp Berger added a comment -

          Here's a patch that i think might fix the issue. It is to be applied to version 2.2-SNAPSHOT in svn trunk (revision 906443).

          Olivier Lamy (*$^¨%`£) added a comment -

          fixed rev 944014
          Thanks!

          Prashant Bhate added a comment -

          Thanks a lot for this patch, Now site deployment would be much quicker.

          it would be nice if url.openStream();

          InputStream in =null;
          
          try
          {
            in = url.openStream();
          

          can be replaced with

          //Define constant TIMEOUT with pre set timeout
           
            InputStream in =null;
          
            try
            {
             URLConnection conn = url.openConnection();
             conn.setConnectTimeout(TIMEOUT);
             conn.setReadTimeout(TIMEOUT);
             in = conn.getInputStream();
          

          url.openStream(); is a blocking call that makes caller wait forever

          Olivier Lamy (*$^¨%`£) added a comment -

          please open a new issue for this.
          Thanks.

          Prashant Bhate added a comment -

          Hi,
          Raised http://jira.codehaus.org/browse/MPIR-199

          Cheers,
          Prashant Bhate

          Dominique Jean-Prost added a comment -

          Well, I think I still meet the same problem.

          My settings.xml :

          <mirrors>
          		<mirror>
          			<mirrorOf>*</mirrorOf>
          			<url>http://vsrigel:7001/archiva/repository/global</url>
          			<id>everything-mirror</id>
          		</mirror>
          		
          	</mirrors>
          

          when I execute "c:\bin\apache-maven-2.2.1\bin\mvn project-info-reports:dependencies", the plugin hangs twice and displays :

          [WARNING] The repository url 'http://repo1.maven.org/maven2' is invalid - Repository 'central' will be blacklisted.
          [WARNING] The repository url 'http://svn.apache.org/maven-snapshot-repository' is invalid - Repository 'apache.snapshots' will be blacklisted.

          I also get tons of
          [DEBUG] Using mirror: http://vsrigel:7001/archiva/repository/global (id: everything-mirror)
          [DEBUG] Using Wagon implementation lightweight from default mapping for protocol http
          [DEBUG] Checking for pre-existing User-Agent configuration.
          [DEBUG] Adding User-Agent configuration.
          http://vsrigel:7001/archiva/repository/global - Session: Opened
          http://vsrigel:7001/archiva/repository/global - Session: Disconnecting
          http://vsrigel:7001/archiva/repository/global - Session: Disconnected

          Please find my execution log as an attachment.
          Should this bug be reopened ? Or am I wrong ?

          Thank you
          Dom

          Dominique Jean-Prost added a comment -

          log that shows bug is still there in org.apache.maven.plugins:maven-project-info-reports-plugin:2.2:dependencies ?


            People

            • Assignee:
              Olivier Lamy (*$^¨%`£)
              Reporter:
              Brian E. Fox
            • Votes:
              16 Vote for this issue
              Watchers:
              17 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development