Uploaded image for project: 'Maven Project Info Reports Plugin'
  1. Maven Project Info Reports Plugin
  2. MPIR-143

Wrong scope/phase requirement documented on project-info-reports:dependencies page

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Incomplete
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      maven 2.0.9

      Description

      After discussion on maven user mailing list (see http://markmail.org/search/?q=sslavic%20list%3Aorg.apache.maven.users#query:sslavic%20list%3Aorg.apache.maven.users+page:2+mid:kkzcdmruemiwpeei+state:results ) conclusion was that wrong scope is documented on following page: http://maven.apache.org/plugins/maven-project-info-reports-plugin/dependencies-mojo.html in Attributes section where instead of "test" in "Requires dependency resolution of artifacts in scope: test." it should stand "package".

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              sslavic Stevo Slavic
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: