Maven Help Plugin
  1. Maven Help Plugin
  2. MPH-52

help:describe never shows "Default Value"

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1
    • Component/s: None
    • Labels:
      None

      Description

      Run "mvn help:describe -Dcmd=help:describe -Dfull". The output should include some default values (e.g. medium's default value is true), but no default values are specified.

      There's code in help:describe to display default values, but strangely the code never activates because the MojoDescriptor's parameters always claim to have a null default value.

        Activity

        Dan Fabulich created issue -
        Dan Fabulich made changes -
        Field Original Value New Value
        Assignee Dan Fabulich [ dfabulich ]
        Dan Fabulich made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Fix Version/s 2.1 [ 12300 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 10:22:20 UTC 2015 [ 1428229340951 ]
        Mark Thomas made changes -
        Workflow jira [ 12721466 ] Default workflow, editable Closed status [ 12762887 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 23:56:10 UTC 2015 [ 1428278170928 ]
        Mark Thomas made changes -
        Workflow jira [ 12958999 ] Default workflow, editable Closed status [ 12995835 ]

          People

          • Assignee:
            Dan Fabulich
            Reporter:
            Dan Fabulich
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development