Uploaded image for project: 'Maven Help Plugin'
  1. Maven Help Plugin
  2. MPH-51

"help:help -Ddetail" looks better than "help:describe -Dplugin=help -Dfull"

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.1
    • Component/s: None
    • Labels:
      None

      Description

      Run "help:help -Ddetail". Looks nice, doesn't it? Run "help:describe -Dplugin=help -Dfull". It's way uglier, and contains lots of irrelevant parameters that the user isn't allowed to specify from the command line.

      Ideally help:describe and help:help would share code so we wouldn't have to worry about this.

        Attachments

          Activity

            People

            • Assignee:
              dfabulich Dan Fabulich
              Reporter:
              dfabulich Dan Fabulich
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: