Maven Project Web Site
  1. Maven Project Web Site
  2. MNGSITE-81

Wrong Root Element in profiles.xml examples used

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      All

      Description

      On the Web-Site http://maven.apache.org/pom.html#Profiles there are examples which use

      <project xmlns="http://maven.apache.org/POM/4.0.0"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
                            http://maven.apache.org/xsd/maven-4.0.0.xsd">
        ...

      But this will produce an error with Maven 2.1.0 ....It is needed to change this into <projectXmls ...>.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          530d 9h 9m 1 Hervé Boutemy 04/Sep/10 16:09
          Mark Thomas made changes -
          Workflow jira [ 12961394 ] Default workflow, editable Closed status [ 12997841 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 00:47:18 UTC 2015 [ 1428281238819 ]
          Mark Thomas made changes -
          Workflow jira [ 12723663 ] Default workflow, editable Closed status [ 12762770 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 12:11:45 UTC 2015 [ 1428235905420 ]
          Hervé Boutemy made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Cannot Reproduce [ 5 ]
          Hervé Boutemy made changes -
          Description On the Web-Site http://maven.apache.org/pom.html#Profiles there are examples which use
          <project xmlns="http://maven.apache.org/POM/4.0.0"
            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
            xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
                                http://maven.apache.org/xsd/maven-4.0.0.xsd">
            ...
          But this will produce an error with Maven 2.1.0 ....It is needed to change this into <projectXmls ...>.

          On the Web-Site http://maven.apache.org/pom.html#Profiles there are examples which use
          {code:xml}<project xmlns="http://maven.apache.org/POM/4.0.0"
            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
            xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
                                http://maven.apache.org/xsd/maven-4.0.0.xsd">
            ...{code}
          But this will produce an error with Maven 2.1.0 ....It is needed to change this into <projectXmls ...>.

          Hervé Boutemy made changes -
          Field Original Value New Value
          Link This issue relates to MNGSITE-102 [ MNGSITE-102 ]
          Benjamin Bentmann added a comment -

          The page your refer to is titled "POM Reference", i.e. is about profiles in the POM. As such, the examples given on this page are correct.

          What would be needed is a document "Profiles Reference" or similar, that addresses the profiles.xml itself.

          It is needed to change this into <projectXmls ...>.

          As per the XSD, <profilesXml> would work better

          Karl Heinz Marbaise created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Karl Heinz Marbaise
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development