Maven
  1. Maven
  2. MNG-868

Use uniform format for <properties> and other tags

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Incomplete
    • Affects Version/s: 2.0-beta-1
    • Fix Version/s: None
    • Labels:
      None

      Description

      In settings.xml, the activationproperties have the format: <property><name/><value/></property>
      whereas the 'user' properties below (which don't have any documentation) have the format
      <my.property.name>my.property.value</my.property.name>.

      They should really be uniform. My personal favourite is ofcourse: <property name="....">....</property>.

      There are more places where duplicate classes are used (repositories,..).

      (Also suggest to remove the <dependencies> tag from <dependencyManagement>
      and make DependencyManagement extend from Dependencies (or, make it a list)., but this
      could prove troublesome.)

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        3054d 11h 29m 1 Jason van Zyl 22/Jan/14 20:31
        Mark Thomas made changes -
        Workflow jira [ 12952665 ] Default workflow, editable Closed status [ 12990008 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 21:45:26 UTC 2015 [ 1428270326204 ]
        Mark Thomas made changes -
        Workflow jira [ 12712134 ] Default workflow, editable Closed status [ 12752086 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 08:49:45 UTC 2015 [ 1428223785911 ]
        Paul Benedict made changes -
        Fix Version/s Issues to be reviewed for 3.x [ 13145 ]
        Jason van Zyl made changes -
        Resolution Incomplete [ 4 ]
        Status Open [ 1 ] Closed [ 6 ]
        Jason van Zyl added a comment -

        Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.

        Jason van Zyl made changes -
        Fix Version/s 3.x [ 13145 ]
        Fix Version/s 3.0 [ 13142 ]
        Jason van Zyl made changes -
        Fix Version/s 2.1 [ 11704 ]
        Fix Version/s 2.1.x [ 13142 ]
        John Casey made changes -
        Assignee John Casey [ jdcasey ]
        Vincent Massol made changes -
        Workflow Maven [ 39417 ] Maven New [ 47865 ]
        John Didion added a comment -

        This is also an issue for plugins that use properties. The plugin documentation states:

        Properties

        This category covers any map which implements java.util.Properties. These parameters are configured by including XML tags in the form <key>value</key> in the parameter configuration.

        However, properties are actually configured using the <property><name/><value/></property> format.

        Maven Developers List added a comment -

        John, with your above comment then is this issue pretty much closed?

        Jason van Zyl made changes -
        Priority Major [ 3 ] Trivial [ 5 ]
        Brett Porter made changes -
        Fix Version/s 2.0-beta-3 [ 12015 ]
        Fix Version/s 2.1 [ 11704 ]
        John Casey made changes -
        Assignee John Casey [ jdcasey ]
        John Casey added a comment -

        The activation property is not the same as any old configuration parameter. For one thing, we're not (currently) supporting combinatorial logic for multiple properties, which means that using a flat MAP style is leaving the door open to problems of multiple property specification. Perhaps I'd better rename the activation property to <systemProperty>, where the separation is more clear.

        In all other cases, properties are a map, or a DOM. In this case, I want the semantics to clearly support one property specification.

        Brett Porter made changes -
        Fix Version/s 2.1 [ 11704 ]
        Fix Version/s 2.0-beta-3 [ 12015 ]
        Brett Porter added a comment -

        I haven't looked closely, but I think that this should be fixed while we still have the opportunity to do it. Otherwise we need to perpetually support it...

        John Casey made changes -
        Fix Version/s 2.1 [ 11704 ]
        Complexity Novice Expert
        Remaining Estimate 2h [ 7200 ]
        Fix Version/s 2.0-beta-3 [ 12015 ]
        Original Estimate 2h [ 7200 ]
        John Casey added a comment -

        this would require a change to the .mdo files, which isn't going to happen until post-2.0-final, especially since it's not a bug.

        We'll revisit syntax for 2.1, and apply lessons learned from 2.0 then.

        Brett Porter made changes -
        Fix Version/s 2.0-beta-2 [ 11861 ]
        Fix Version/s 2.0-beta-3 [ 12015 ]
        Brett Porter made changes -
        Component/s design [ 11341 ]
        Brett Porter made changes -
        Field Original Value New Value
        Fix Version/s 2.0-beta-2 [ 11861 ]
        Fix Version/s 2.0-beta-1 [ 11040 ]
        Brett Porter added a comment -

        no more changes for beta-1

        Kenney Westerhof created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Kenney Westerhof
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2h
              2h
              Remaining:
              Remaining Estimate - 2h
              2h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development