Uploaded image for project: 'Maven'
  1. Maven
  2. MNG-6798

build-helper-maven-plugin: java.lang.IllegalArgumentException: version can neither be null, empty nor blank

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 3.6.2
    • Fix Version/s: None
    • Component/s: Plugins and Lifecycle
    • Labels:
      None

      Description

      After upgrading to maven 3.6.2 I found that I could no longer successfully build one of my projects.  The error:

      [ERROR] Failed to execute goal org.codehaus.mojo:build-helper-maven-plugin:3.0.0:released-version (released-version) on project forge-gui-desktop: Execution released-version of goal org.codehaus.mojo:build-helper-maven-plugin:3.0.0:released-version failed: version can neither be null, empty nor blank -> [Help 1]

      seemed to indicate a problem with one of the plugins, specifically build-helper-maven-plugin.  However, I have found that rolling maven (and only maven) back to 3.6.1 allows the project to build.  So, this appears to be a problem with maven and not the plugin.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jamincollins Jamin Collins
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: