Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 3.0.1
    • Component/s: None
    • Labels:
      None
    • Environment:
      windows vista sp2 32 bits on a hp dv5 laptop

      Description

      Please find attached the debug log as requested by the url presented on the error itself

      1. debug.log
        18 kB
        Ricardo Espirito Santo

        Activity

        Benjamin Bentmann added a comment -

        The issue is the following snippet from the plugin's components.xml:

        <lifecycle>
          <id>coverage</id>
          <phases>
            <phase>
              <id>test</id>
              <configuration>
                <testFailureIgnore>true</testFailureIgnore>
              </configuration>
            </phase>
          </phases>
        </lifecycle>
        

        This syntax is wrong. It gets silently ignored by Maven 2.x and fails as reported here with Maven 3.x. So in any case, this should be reported against the maven-dotnet-plugin as well.

        Stuart McCulloch added a comment - - edited

        The container issue to turn this error into a warning is: https://issues.sonatype.org/browse/SISU-18

        Benjamin Bentmann added a comment -

        Fixed in r1036674.


          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Ricardo Espirito Santo
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development