Uploaded image for project: 'Maven'
  1. Maven
  2. MNG-4151

Update maven API to use Java 5 generics

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 3.0
    • Component/s: IDEs
    • Labels:
      None

      Description

      As Maven 2.2.x requires Java 5, upgrade maven API to use generics on collections. This will help plugin developers to avoid classCastException and make the API more comprehensible.

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              ndeloof nicolas de loof

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment