Uploaded image for project: 'Maven'
  1. Maven
  2. MNG-3746

POM properties do not override default system properties during POM interpolation

    Details

      Description

      From Paul Benedict, on the maven dev list:

      My issue might be related to MNG-3535.
      
      I defined this property:
      <java.version>1.6</java.version>
      
      And used it in my compiler plugin:
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-compiler-plugin</artifactId>
        <configuration>
          <source>${java.version}</source>
          <target>${java.version}</target>
        </configuration>
      </plugin>
      
      I know this use to work before 2.0.10, but now it does not.
      [INFO] Compilation failure
      Failure executing javac, but could not parse the error:
      javac: invalid target release: 1.6.0_06
      Usage: javac <options> <source files>
      use -help for a list of possible options
      
      The error here is that ${java.version} is not the value I specified,
      but one that already exists.
      
      Paul
      

      I've replicated the problem in a separate test mock-up project.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jdcasey John Casey
                Reporter:
                jdcasey John Casey
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: