Maven
  1. Maven
  2. MNG-3650

[regression] error reporting can not properly report a missing extension artifact

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0-alpha-1
    • Fix Version/s: 3.0
    • Component/s: Errors
    • Labels:
      None

      Description

      note the following log - without -X, you wouldn't know that the problem was that the extension was not found

      1. error-reporting.txt
        19 kB
        Brett Porter
      2. pom.xml
        0.8 kB
        Brett Porter

        Activity

        Brett Porter created issue -
        Brett Porter made changes -
        Field Original Value New Value
        Fix Version/s 2.1-alpha-1 [ 13143 ]
        Jason van Zyl added a comment -

        I cannot actually tell what you ran to get this, or what the POM looks like to test it.

        Jason van Zyl made changes -
        Resolution Incomplete [ 4 ]
        Status Open [ 1 ] Closed [ 6 ]
        Brett Porter added a comment -

        see attached POM.

        In 2.0.9:

        [INFO] Error retrieving previous build number for artifact 'test:MNG-3650:jar': repository metadata for: 'snapshot test:MNG-3650:1.0-SNAPSHOT' could not be retrieved from repository: releases due to an error: Unsupported Protocol: 'foo': Cannot find wagon which supports the requested protocol: foo
        

        Not great, but the error is there at the end.

        In 3.0-SNAPSHOT:

        Internal error in the plugin manager executing goal 'org.apache.maven.plugins:maven-deploy-plugin:2.3:deploy': Mojo execution failed.
        
        Brett Porter made changes -
        Status Closed [ 6 ] Reopened [ 4 ]
        Resolution Incomplete [ 4 ]
        Brett Porter made changes -
        Attachment pom.xml [ 37369 ]
        Brian Fox made changes -
        Fix Version/s 3.0-alpha-2 [ 14430 ]
        Fix Version/s 3.0-alpha-1 [ 13143 ]
        Brian Fox made changes -
        Fix Version/s 3.0-alpha-2 [ 14430 ]
        Fix Version/s 3.0-alpha-3 [ 14719 ]
        Jason van Zyl made changes -
        Fix Version/s 3.x [ 13145 ]
        Fix Version/s 3.0-alpha-3 [ 14719 ]
        Brett Porter made changes -
        Link This issue is duplicated by MNG-3330 [ MNG-3330 ]
        Brett Porter made changes -
        Link This issue is duplicated by MNG-3330 [ MNG-3330 ]
        Benjamin Bentmann made changes -
        Assignee Benjamin Bentmann [ bentmann ]
        Status Reopened [ 4 ] Closed [ 6 ]
        Fix Version/s 3.0 [ 13142 ]
        Resolution Fixed [ 1 ]
        Fix Version/s Issues to be reviewed for 3.x [ 13145 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 08:49:45 UTC 2015 [ 1428223785911 ]
        Mark Thomas made changes -
        Workflow jira [ 12714053 ] Default workflow, editable Closed status [ 12753666 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 21:45:26 UTC 2015 [ 1428270326204 ]
        Mark Thomas made changes -
        Workflow jira [ 12950639 ] Default workflow, editable Closed status [ 12986852 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        90d 17h 49m 1 Jason van Zyl 02/Oct/08 15:55
        Closed Closed Reopened Reopened
        5h 31m 1 Brett Porter 02/Oct/08 21:26
        Reopened Reopened Closed Closed
        779d 14h 9m 1 Benjamin Bentmann 21/Nov/10 10:35

          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Brett Porter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development