Uploaded image for project: 'Maven'
  1. Maven
  2. MNG-2807

ciManagement from parent is not merging with children

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Incomplete
    • Affects Version/s: 2.0.4
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      linux jdk1.5.0_10 amd64

      Description

      If I define the following in my parent pom:

      <ciManagement>
        <system>continuum</system>
        <url>http://blah</url>
      </ciManagement>
      

      and then in the child pom I have the following:

      <ciManagement>
        <notifiers>
          <notifier>
            <type>mail</type>
            <configuration>
              <address>blah</address>
            </configuration>
          </notifier>
        </notifiers>
      </ciManagement>
      

      The ciManagement for the effective pom lacks the system and url properties from the parent pom. Seems like it should be merging them but isn't. This would helpful for reducing code duplication.

        Issue Links

          Activity

          paul4christ79 Paul Benedict added a comment -

          Removed specified fixed version.

          jvanzyl Jason van Zyl added a comment -

          Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.

          hboutemy Hervé Boutemy added a comment -

          MNG-3124 is exactly the same expectations and limits for mailing lists

          brettporter Brett Porter added a comment -

          need to review the role of these elements in a POM review. They might be better just being general "configuration" across a set of plugins

          brettporter Brett Porter added a comment -

          this is currently by design - will need to review it in light of a model change

          paul4christ79 Paul Benedict added a comment - - edited

          This would greatly help when submodules are ran by different developers. The software engineers can be placed in the parent POM, and additional developers notified via the children POM. In the company I work for, we aren't allowed to have custom mailing lists – so we have to list people (i.e., developers) individually in the POM. A pain, yes, but if this element was inheritable, it would be easier to deal with our constraint.


            People

            • Assignee:
              Unassigned
              Reporter:
              kldavis4 Kelly Davis
            • Votes:
              7 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development