Maven Javadoc Plugin
  1. Maven Javadoc Plugin
  2. MJAVADOC-341

The javadoc.bat file created in the apidocs directory by using <debug>true</debug> causes site deployment to fail

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Not A Problem
    • Affects Version/s: 2.8.1
    • Fix Version/s: None
    • Labels:
      None

      Description

      I'm deploying to MS Sharepoint via WevDAV with wagon-webdav-jackrabit.

      mvn site-deploy fails while trying to upload javadoc.bat with HTTP error 414.

      Maybe javadoc.

      {bat,sh}

      should be created outside target/site?

        Activity

        Adrián Boimvaser created issue -
        Hervé Boutemy added a comment -

        commands are really launched from target/site/apidocs: creating the script outside would mean the script would not represent really what is running
        so bad idea

        you should disable debug if this causes trouble with your target deploy

        Hervé Boutemy made changes -
        Field Original Value New Value
        Assignee Herve Boutemy [ hboutemy ]
        Resolution Not A Bug [ 6 ]
        Status Open [ 1 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 11:56:47 UTC 2015 [ 1428235007093 ]
        Mark Thomas made changes -
        Workflow jira [ 12722573 ] Default workflow, editable Closed status [ 12762268 ]
        Mark Thomas made changes -
        Project Import Mon Apr 06 00:11:46 UTC 2015 [ 1428279106587 ]
        Mark Thomas made changes -
        Workflow jira [ 12960154 ] Default workflow, editable Closed status [ 12997021 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        848d 21h 18m 1 Hervé Boutemy 08/Jun/14 12:08

          People

          • Assignee:
            Hervé Boutemy
            Reporter:
            Adrián Boimvaser
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development