Maven Javadoc Plugin
  1. Maven Javadoc Plugin
  2. MJAVADOC-284

detectOfflineLinks sets off extra spurious executions of javadoc

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.1
    • Fix Version/s: 2.8
    • Labels:
      None

      Description

      I have an aggregate project. In pluginManagement, I spec out javadoc:jar. In the leaf projects, I turn it on with an ordinary <plugin/> for the plugin.

      If I leave detectOfflineLinks with its default value of true, the javadoc plugin uses the invoker plugin to relaunch itself, recursively, complaining that it hasn't been run on one or another of the projects. Note that, when this happens, it is 'swimming upstream' – it is processing project A, it invokes itself on project B, where B depends on A, not the other way around.

      If I run maven just in the leaf directories all is well. The trouble only happens when running maven from the aggregating parent.

      Just to clarify, in case I don't get a test case together too soon ...

      external/corporate parent:

      javadoc only mentioned in the <reporting> section.

      aggregating parent:

      javadoc only mentioned in pluginManagement, setting up execution of javadoc:jar.

      leaf:

      A very plain 'plugin' element just to turn on the configuration from plugin management.

      mvn run from leaf: all is well.

      mvn run from aggregating parent: lots of extra 'invoker' invocations of javadoc on projects that have dependencies on the current project.

        Issue Links

          Activity

          Benson Margulies created issue -
          Benjamin Bentmann made changes -
          Field Original Value New Value
          Link This issue relates to MJAVADOC-275 [ MJAVADOC-275 ]
          Hervé Boutemy added a comment -

          can you provide a sample project causing such problem, please?

          Hervé Boutemy made changes -
          Link This issue is related to MJAVADOC-286 [ MJAVADOC-286 ]
          Hervé Boutemy made changes -
          Link This issue relates to MJAVADOC-268 [ MJAVADOC-268 ]
          Benson Margulies added a comment -
          svn co https://svn.apache.org/repos/asf/mahout/trunk
          maven 3.0 ...
          mvn -Prelease
          
          Hervé Boutemy added a comment -

          I just tested and cannot reproduce any problem
          In fact, I can't reproduce any problem now, but I'm sure a few months ago I had the same problems as you (but I changed computer in the meaning time: perhaps this could have an unexpected impact)
          Can you confrirm you're still having problems with mahout?
          If yes, please attach "mvn -X ..." output: perhaps I'll se something
          And if you can update javadoc plugin to 1.8-SNAPSHOT and attach output, it would be great too: I added some traces to help investigate

          Hervé Boutemy made changes -
          Link This issue is related to MJAVADOC-181 [ MJAVADOC-181 ]
          Hervé Boutemy added a comment -

          fixed in r1058359

          Hervé Boutemy made changes -
          Assignee Herve Boutemy [ hboutemy ]
          Fix Version/s 2.8 [ 16433 ]
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Hervé Boutemy made changes -
          Link This issue is duplicated by MJAVADOC-295 [ MJAVADOC-295 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 11:56:47 UTC 2015 [ 1428235007093 ]
          Mark Thomas made changes -
          Workflow jira [ 12722519 ] Default workflow, editable Closed status [ 12762380 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 00:11:46 UTC 2015 [ 1428279106587 ]
          Mark Thomas made changes -
          Workflow jira [ 12960103 ] Default workflow, editable Closed status [ 12996989 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          253d 9h 13m 1 Hervé Boutemy 12/Jan/11 17:56

            People

            • Assignee:
              Hervé Boutemy
              Reporter:
              Benson Margulies
            • Votes:
              5 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development