Maven Javadoc Plugin
  1. Maven Javadoc Plugin
  2. MJAVADOC-275

Creation of Javadoc attachments fails in multi-module project where modules have never been installed/deployed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.6.1
    • Fix Version/s: 2.8
    • Labels:
      None

      Description

      Running the commands

      mvn clean
      mvn verify
      

      will fail on the attached demo project with

      [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6.1:javadoc'
        has not be previously called for the project: 'org.apache.maven.its.javadoc:mod-b:jar:0.1'.
        Trying to invoke it...
      [ERROR] MavenInvocationException: Error when invoking Maven, consult the invoker log file:
        M:\MJAVADOC\mod-a\target\invoker\maven-javadoc-plugin625147587.txt
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] MavenReportException: Error while creating archive:
        Error when invoking Maven, consult the invoker log file: 
        M:\MJAVADOC\mod-a\target\invoker\maven-javadoc-plugin625147587.txt
      

      The command mvn clean verify as usually used during releases will also fail, but starts working after repeated invocations.

      1. MJAVADOC-275.zip
        4 kB
        Benjamin Bentmann

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          150d 6h 59m 1 John Casey 13/Apr/10 15:51
          Closed Closed Reopened Reopened
          298d 6h 41m 1 Dan Tran 05/Feb/11 21:33
          Reopened Reopened Closed Closed
          78d 5h 40m 1 Hervé Boutemy 25/Apr/11 04:14
          Mark Thomas made changes -
          Workflow jira [ 12960006 ] Default workflow, editable Closed status [ 12996909 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 00:11:46 UTC 2015 [ 1428279106587 ]
          Mark Thomas made changes -
          Workflow jira [ 12722510 ] Default workflow, editable Closed status [ 12762387 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 11:56:47 UTC 2015 [ 1428235007093 ]
          Hervé Boutemy made changes -
          Status Reopened [ 4 ] Closed [ 6 ]
          Fix Version/s 2.7 [ 15050 ]
          Resolution Fixed [ 1 ]
          Fix Version/s 2.8 [ 16433 ]
          Hervé Boutemy added a comment -

          yes, with MJAVADOC-284 fixed, this issue is a duplicate IMHO

          John Casey added a comment -

          what about 2.8? can we close this issue now that MJAVADOC-284 is closed? I haven't seen it, unless you're talking about the case where the javadoc plugin forks a new build in order to produce javadocs for dependencies...for which there is a flag to skip that, and I'm assuming MJAVADOC-284 has fixed in a more permanent way.

          Dan Tran made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Dan Tran added a comment -

          reopen since javadoc plugin 2.7 still see the same issue

          Yegor Bugayenko added a comment -

          The problem is still not fixed. Why the issue is closed?

          Dinesh Mehta added a comment -

          I still see this error with v2.7. What are the configurations to run the plugin in aggreagte mode for a multi-module project?

          Benjamin Bentmann made changes -
          Link This issue is related to MJAVADOC-284 [ MJAVADOC-284 ]
          Frederick N. Brier added a comment -

          I believe I was having this issue with version 2.6.1/Maven 2.2.1. If I comment out the plugin, it builds fine. Otherwise, the preceding sibling dependency is "missing". I just checked out/built/installed the 2.7-SNAPSHOT and the error is still occurring.

          John Casey made changes -
          Resolution Fixed [ 1 ]
          Fix Version/s 2.7 [ 15050 ]
          Status Open [ 1 ] Closed [ 6 ]
          John Casey made changes -
          Link This issue is depended upon by MJAVADOC-276 [ MJAVADOC-276 ]
          John Casey made changes -
          Assignee John Casey [ jdcasey ]
          Harold Shinsato added a comment -

          This is happening for us only during release:perform - is there any workaround? It's confusing why the javadoc for one project gets invoked from another project.

          Hans Beemsterboer added a comment -

          I had a similar issue, while running: mvn site.
          After explicitly running: mvn javadoc:javadoc, this issue didn't occur any more.

          Benjamin Bentmann added a comment -

          This is in particular problematic as not even "mvn install" makes it work.

          Julien HENRY added a comment -

          I agree I think this is the same issue.

          Benjamin Bentmann added a comment -

          I guess that the same issue already reported as Regression with maven-javadoc-plugin 2.6.1 and release:perform.

          Benjamin Bentmann made changes -
          Field Original Value New Value
          Attachment MJAVADOC-275.zip [ 45851 ]
          Benjamin Bentmann created issue -

            People

            • Assignee:
              John Casey
              Reporter:
              Benjamin Bentmann
            • Votes:
              12 Vote for this issue
              Watchers:
              15 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development