Uploaded image for project: 'Maven Invoker Plugin'
  1. Maven Invoker Plugin
  2. MINVOKER-164

Maven Invoker still using -r option when such is no longer supported

    Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0
    • Labels:
      None
    • Environment:
      Default locale: en_US, platform encoding: UTF-8
      OS name: "mac os x", version: "10.9.2", arch: "x86_64", family: "mac"

      Description

      Maven Invoker Version: 2.1.1

      Maven Invoker is still using -r when such is not supported anymore. http://maven.apache.org/ref/3.2.1/maven-embedder/cli.html

      This is affecting https://jira.codehaus.org/browse/MREACTOR-22

              if ( request.isActivatedReactor() )
              {
                  cli.createArg().setValue( "-r" );
                  String[] includes = request.getActivatedReactorIncludes();
                  String[] excludes = request.getActivatedReactorExcludes();
                  if ( includes != null )
                  {
                      cli.createArg().setValue( "-D" );
                      cli.createArg().setValue( "maven.reactor.includes=" + StringUtils.join( includes, "," ) );
                  }
                  if ( excludes != null )
                  {
                      cli.createArg().setValue( "-D" );
                      cli.createArg().setValue( "maven.reactor.excludes=" + StringUtils.join( excludes, "," ) );
                  }
              }
      

        Issue Links

          Activity

          khmarbaise Karl Heinz Marbaise added a comment - - edited

          The problem is that Maven Invoker Plugin supports also Maven 2 which has such an option. This could be removed if we drop Maven 2 support for the maven-invoker-plugin.

          khmarbaise Karl Heinz Marbaise added a comment -

          Upgrade to maven-invoker shared component 3.0.0-SNAPSHOT which drops Maven 2 support.

          khmarbaise Karl Heinz Marbaise added a comment -

          Done in r1752081

          hudson Hudson added a comment -

          SUCCESS: Integrated in maven-plugins #6898 (See https://builds.apache.org/job/maven-plugins/6898/)
          MINVOKER-164 Maven Invoker still using -r option when such is no longer supported
          o Drop Maven 2 support using maven-invoker component 3.0.0 (khmarbaise: http://svn.apache.org/viewvc/?view=rev&rev=1752081)

          • maven-invoker-plugin/pom.xml
          • maven-invoker-plugin/src/main/java/org/apache/maven/plugin/invoker/AbstractInvokerMojo.java
          • maven-invoker-plugin/src/main/java/org/apache/maven/plugin/invoker/InvokerProperties.java
          • maven-invoker-plugin/src/test/java/org/apache/maven/plugin/invoker/InvokerPropertiesTest.java

            People

            • Assignee:
              khmarbaise Karl Heinz Marbaise
              Reporter:
              jccarrillo JC Carrillo
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development