Uploaded image for project: 'Maven Install Plugin'
  1. Maven Install Plugin
  2. MINSTALL-71

localRepositoryPath ignored

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.3
    • Component/s: install:install-file
    • Labels:
      None
    • Environment:

      Description

      Using CLI I want to install an artifact in an other repository than the on defined in my settings.xml. Here is the command line I use :

      mvn -X org.apache.maven.plugins:maven-install-plugin:2.2:install-file -DlocalRepositoryPath=D:\RPE_WS\fake_repo -Dfile=inst_test-0.0.1.jar -DpomFile=pom.xml -DcreateChecksum=true

      where D:\RPE_WS\fake_repo is an empty directory

      The last part of the output is:

      ...
      [DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-install-plugin:2.2:inst
      all-file' -->
      [DEBUG] (f) createChecksum = true
      [DEBUG] (f) file = D:\RPE_WS\mvn_install_test\inst_test-0.0.1.jar
      [DEBUG] (f) generatePom = false
      [DEBUG] (f) localRepository = Repository[local|file://C:\Documents and Setting
      s\gt218354\.m2\repository]
      [DEBUG] (s) localRepositoryPath = D:\RPE_WS\fake_repo
      [DEBUG] (f) pomFile = D:\RPE_WS\mvn_install_test\pom.xml
      [DEBUG] (f) repositoryLayout = default
      [DEBUG] – end configuration –
      [INFO] [install:install-file

      {execution: default-cli}

      ]
      [INFO] Installing D:\RPE_WS\mvn_install_test\inst_test-0.0.1.jar to C:\Documents
      and Settings\userid\.m2\repository\com\plop\test\inst_test\0.0.1\inst_test-0
      .0.1.jar
      [INFO] Creating Checksums...
      [DEBUG] Installing checksum for C:\Documents and Settings\userid\.m2\repository\com\plop\test\inst_test\0.0.1\inst_test-0.0.1.jar
      [INFO] Installing D:\RPE_WS\mvn_install_test\pom.xml to C:\Documents and Setting
      s\userid\.m2\repository\com\plop\test\inst_test\0.0.1\inst_test-0.0.1.pom
      [INFO] Creating Checksums...
      [DEBUG] Installing checksum for C:\Documents and Settings\userid\.m2\repositor
      y\com\plop\test\inst_test\0.0.1\inst_test-0.0.1.pom
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD SUCCESSFUL
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: < 1 second
      [INFO] Finished at: Thu Nov 26 12:02:57 CET 2009
      [INFO] Final Memory: 3M/6M
      [INFO] ------------------------------------------------------------------------

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              jetto RĂ©mi Perrot
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: