Uploaded image for project: 'Maven Install Plugin'
  1. Maven Install Plugin
  2. MINSTALL-37

Add support to force install:install to use a specific version

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Flags:
      Patch

      Description

      Allow the install:install goal to force the version of artifacts (including attached).

        Issue Links

          Activity

          jason@planet57.com Jason Dillon added a comment -

          The attached patch adds support for an optional forceVersion parameter which is a String. When non-null, this will cause new artifacts to be created with their versions set to the value of forceVersion.

          This does not affect current usage of install:install, with out forceVersion set the goal behaves exactly as it did before.

          This feature is intended to support testing and some other edge cases, but not intended for mainstream usage.

          brianf@infinity.nu Brian E. Fox (imported) added a comment -

          this patch looks ok, but the classifier should be passed through to the factory instead of null.

          snicoll Stephane Nicoll added a comment -

          Brian, I guess MINSTALL-30 is rather a duplicate of this one. WDYT?

          brianf@infinity.nu Brian E. Fox (imported) added a comment -

          Similar, but not exactly a duplicate.

          brianf@infinity.nu Brian E. Fox (imported) added a comment -

          The general consensus seems to be that this should not be added.

          dennisl@apache.org Dennis Lundberg added a comment -

          Remove "Fix Version" as the issue was not fixed.


            People

            • Assignee:
              brianf Brian Fox
              Reporter:
              jason@planet57.com Jason Dillon
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development