Uploaded image for project: 'Metron'
  1. Metron
  2. METRON-1102

Add support for ingesting cybox URI observables from taxii feeds

    Details

    • Type: Bug
    • Status: Done
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 0.4.1
    • Labels:
      None

      Description

      There would be value in ingesting URIs from taxii feeds. As of now, we do not do this.

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          GitHub user cestella opened a pull request:

          https://github.com/apache/metron/pull/689

          METRON-1102: Add support for ingesting cybox URI observables from taxii feeds

            1. Contributor Comments
              There is value in ingesting URIs from taxii feeds and we should provide support to do so.

          NOTE: This presumes a working Taxii which is corrected in METRON-1026 ( #643)

            1. Pull Request Checklist

          Thank you for submitting a contribution to Apache Metron.
          Please refer to our [Development Guidelines](https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=61332235) for the complete guide to follow for contributions.
          Please refer also to our [Build Verification Guidelines](https://cwiki.apache.org/confluence/display/METRON/Verifying+Builds?show-miniview) for complete smoke testing guides.

          In order to streamline the review of the contribution we ask you follow these guidelines and ask you to double check the following:

              1. For all changes:
              1. For code changes:
          • [x] Have you included steps to reproduce the behavior or problem that is being changed or addressed?
          • [x] Have you included steps or a guide to how the change may be verified and tested manually?
          • [x] Have you ensured that the full suite of tests and checks have been executed in the root metron folder via:
            ```
            mvn -q clean integration-test install && build_utils/verify_licenses.sh
            ```
          • [x] Have you written or updated unit tests and or integration tests to verify your changes?
          • [x] If adding new dependencies to the code, are these dependencies licensed in a way that is compatible for inclusion under [ASF 2.0](http://www.apache.org/legal/resolved.html#category-a)?
          • [x] Have you verified the basic functionality of the build by building and running locally with Vagrant full-dev environment or the equivalent?
              1. For documentation related changes:
          • [x] Have you ensured that format looks appropriate for the output in which it is rendered by building and verifying the site-book? If not then run the following commands and the verify changes via `site-book/target/site/index.html`:

          ```
          cd site-book
          mvn site
          ```

                1. Note:
                  Please ensure that once the PR is submitted, you check travis-ci for build issues and submit an update to your PR as soon as possible.
                  It is also recommended that [travis-ci](https://travis-ci.org) is set up for your personal repository such that your branches are built there before submitting a pull request.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/cestella/incubator-metron taxii_uri

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/metron/pull/689.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #689


          commit 2d0e597c3fe8efec9e3ff5d5c98e949b70cddd85
          Author: cstella <cestella@gmail.com>
          Date: 2017-08-10T00:02:42Z

          Add URI Stix type handler


          githubbot ASF GitHub Bot added a comment -

          Github user cestella commented on the issue:

          https://github.com/apache/metron/pull/689

          Testing plan should be the same as [here](https://github.com/apache/metron/pull/643#issuecomment-321415666)

          githubbot ASF GitHub Bot added a comment -

          Github user simonellistonball commented on a diff in the pull request:

          https://github.com/apache/metron/pull/689#discussion_r132347288

          — Diff: metron-platform/metron-data-management/src/main/java/org/apache/metron/dataloads/extractor/stix/StixExtractor.java —
          @@ -38,6 +39,7 @@
          import java.util.Map;

          public class StixExtractor implements Extractor {
          + private static final Logger LOG = Logger.getLogger(StixExtractor.class);
          — End diff –

          Didn't we change how logging worked in METRON-975? @mmiklavc see also #599

          githubbot ASF GitHub Bot added a comment -

          Github user ottobackwards commented on the issue:

          https://github.com/apache/metron/pull/689

          So,

          I think this is a great addition, but I have some comments.

          • Where is the documentation for the version of Stix and the Version of Cybox metron supports?
          • How is the extractor factored to handle support for other versions?
          • How is the extractor factored to handle JSON if / when stix and cybox change over?
          • Can we handle just Cybox? Should this be factored to support them separately?
          • Where is the documentation for the support in this PR?
          githubbot ASF GitHub Bot added a comment -

          Github user cestella commented on the issue:

          https://github.com/apache/metron/pull/689

          Ok, so good questions @ottobackwards . I'll do my best to answer them, but the answer to some of these expands past this PR and to the history of Taxii support for Metron (which was one of the first things we added and thus at a period of time where documentation was scarcer than it is even now )

          • `Where is the documentation for the version of Stix and the Version of Cybox metron supports?`
            We do not currently document that, the answer is, however, that our support for Stix, cybox and taxii is entirely bound up in the mitre java-stix library. We use the most current version [released](https://github.com/STIXProject/java-stix/tree/v1.2.0.2), which is 1.2.0.2.
          • `How is the extractor factored to handle support for other versions?`
            The extractor is handled to support other versions only insomuch as the java-stix library can support multiple versions. As this is officially supported by the stix project, I think that it's backwards compatible, but there may be nuance here that I'm missing.
          • `How is the extractor factored to handle JSON if / when stix and cybox change over?`
            The extractor abstraction works at the level of the object model that the java-stix library provides us rather than doing actual parsing (i.e. we implement support for new types by providing a handler that looks for objects of that type as the output of the parse). If Stix moves to JSON, presumably the library will handle that transparently or we'll need another approach.
          • `Can we handle just Cybox? Should this be factored to support them separately?`
            We can create handlers for anything the java-stix library can parse, but cybox seems to be common and officially supported by the stix project.
          • `Where is the documentation for the support in this PR?`
            I added the new URI type to the README.md in metron-data-management. Since that's the scope of this PR, not to document better our taxii/stix/etc support.

          Ok, so it's apparent that some of the design decisions around taxii never made it into documentation. A couple of questions for you:

          • Where should that documentation live?
          • Are we unhappy enough about having our abstraction bound to the (from what I can tell only) java library provided by the stix project that you'd like to start a discuss thread about developing a better approach to taxii?

          Just a note on the second, we chose that because it was the only game in town other than parsing the XML ourselves and it was the officially supported library. I even looked into that and decided against it as the XML format is extremely complex with lots of referential links that need to get coalesced to handle the blocks of stix that come across.

          githubbot ASF GitHub Bot added a comment -

          Github user ottobackwards commented on the issue:

          https://github.com/apache/metron/pull/689

          > Can we handle just Cybox

          What I mean is, can we import a file that is *ONLY* cybox observables, without Stix.

          Stix supports cybox. But they are separate things.

          githubbot ASF GitHub Bot added a comment -

          Github user ottobackwards commented on the issue:

          https://github.com/apache/metron/pull/689

          As for where... over in METRON-777 @mmiklavc is talking about a better documentation area... this may fall into that

          githubbot ASF GitHub Bot added a comment -

          Github user cestella commented on the issue:

          https://github.com/apache/metron/pull/689

          Ah, for the moment we only have the StixExtractor. We could MAKE a cybox extractor and it could reuse the handler logic, but we haven't done that.

          githubbot ASF GitHub Bot added a comment -

          Github user cestella commented on the issue:

          https://github.com/apache/metron/pull/689

          Yeah, it seems to me that we might need something like a location for discussion and description of architectural decisions made.

          githubbot ASF GitHub Bot added a comment -

          Github user ottobackwards commented on the issue:

          https://github.com/apache/metron/pull/689

          I would like to see at least the version of Stix and Cybox that is supported documented.

          githubbot ASF GitHub Bot added a comment -

          Github user cestella commented on the issue:

          https://github.com/apache/metron/pull/689

          Sure, not a problem. I noted the versions supported in the documentation and linked to the actual schemata for cybox and stix.

          githubbot ASF GitHub Bot added a comment -

          Github user ottobackwards commented on the issue:

          https://github.com/apache/metron/pull/689

          +1 by inspection.

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/metron/pull/689


            People

            • Assignee:
              cestella Casey Stella
              Reporter:
              cestella Casey Stella
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development