Uploaded image for project: 'Metron'
  1. Metron
  2. METRON-1011

Stellar ENRICHMENT functions should enforce submission of 4 parameters

    Details

    • Type: Bug
    • Status: Done
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 0.4.0
    • Fix Version/s: 0.4.1
    • Labels:
      None

      Description

      Currently the Stellar functions ENRICHMENT_EXISTS and ENRICHMENT_GET only check for params 'enrichment_type' and 'indicator' to be submitted by the user. In reality all 4 params are mandatory as ArrayIndexOutOfBoundsExceptions are thrown at anything less than 4

        Issue Links

          Activity

          jasperknulst Jasper Knulst added a comment -

          Steps to reproduce (old behaviour):

          first do a valid Stellar enrichment_get:
          ENRICHMENT_GET('mlkp','POST','enrichment','t')

          now issue:
          ENRICHMENT_GET('mlkp')

          You'll get "java.lang.IllegalStateException: Requires at least an enrichment type and indicator" which makes one believe only 2 parameters are mandatory

          But in fact all 4 parameters are mandatory, as anything less then 4 will get you:

          ENRICHMENT_GET(null,null,null)

          [!] Index: 3, Size: 3
          java.lang.IndexOutOfBoundsException: Index: 3, Size: 3

          --------------

          New behaviour:

          Anything but exactly 4 parameters will get you:

          java.lang.IllegalStateException: All parameters are mandatory, submit 'enrichment type', 'indicator', 'nosql_table' and 'column_family'

          A much clearer problem statement..

          githubbot ASF GitHub Bot added a comment -

          GitHub user jasper-k opened a pull request:

          https://github.com/apache/metron/pull/628

          METRON-1011 Enforce submission of 4 params Stellar ENRICHMENT functions

            1. Contributor Comments
              [Please place any comments here. A description of the problem/enhancement, how to reproduce the issue, your testing methodology, etc.]
            1. Pull Request Checklist

          Thank you for submitting a contribution to Apache Metron.
          Please refer to our [Development Guidelines](https://cwiki.apache.org/confluence/pages/viewpage.action?pageId=61332235) for the complete guide to follow for contributions.
          Please refer also to our [Build Verification Guidelines](https://cwiki.apache.org/confluence/display/METRON/Verifying+Builds?show-miniview) for complete smoke testing guides.

          In order to streamline the review of the contribution we ask you follow these guidelines and ask you to double check the following:

              1. For all changes:
              1. For code changes:
          • [ ] Have you included steps to reproduce the behavior or problem that is being changed or addressed?
          • [ ] Have you included steps or a guide to how the change may be verified and tested manually?
          • [ ] Have you ensured that the full suite of tests and checks have been executed in the root incubating-metron folder via:
            ```
            mvn -q clean integration-test install && build_utils/verify_licenses.sh
            ```
          • [ ] Have you written or updated unit tests and or integration tests to verify your changes?
          • [ ] If adding new dependencies to the code, are these dependencies licensed in a way that is compatible for inclusion under [ASF 2.0](http://www.apache.org/legal/resolved.html#category-a)?
          • [ ] Have you verified the basic functionality of the build by building and running locally with Vagrant full-dev environment or the equivalent?
              1. For documentation related changes:
          • [ ] Have you ensured that format looks appropriate for the output in which it is rendered by building and verifying the site-book? If not then run the following commands and the verify changes via `site-book/target/site/index.html`:

          ```
          cd site-book
          mvn site
          ```

                1. Note:
                  Please ensure that once the PR is submitted, you check travis-ci for build issues and submit an update to your PR as soon as possible.
                  It is also recommended that [travis-ci](https://travis-ci.org) is set up for your personal repository such that your branches are built there before submitting a pull request.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/jasper-k/metron-apache master

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/metron/pull/628.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #628


          commit e79952c6bf6dc3418b5a3d5305e3b198212fd9f5
          Author: jknulst <jknulst@hortonworks.com>
          Date: 2017-07-03T09:14:55Z

          METRON-1011 Enforce 4 parameters on Stellar HBase enrichment functions

          commit 650fd43ea7fcbdfd0b738bf15d82f8e14f70f4be
          Author: jknulst <jknulst@hortonworks.com>
          Date: 2017-07-03T10:17:40Z

          METRON-1011 Added test


          githubbot ASF GitHub Bot added a comment -

          Github user ottobackwards commented on the issue:

          https://github.com/apache/metron/pull/628

          Hi Jasper, thanks for the submission. Can you please fill out the PR template above? The contributor comment section ( This is a PR to XXXX because YYYY by doing ZZZZZ, test this by doing 1,2,3,4,5 ) is important for reviewers.

          githubbot ASF GitHub Bot added a comment -

          Github user ottobackwards commented on the issue:

          https://github.com/apache/metron/pull/628

          +1 by inspection pending filling out the PR template. Thanks for the contribution Jasper!

          githubbot ASF GitHub Bot added a comment -

          Github user jasper-k commented on the issue:

          https://github.com/apache/metron/pull/628

          @ottobackwards regarding the merge conflict, something I need to do?

          githubbot ASF GitHub Bot added a comment -

          Github user ottobackwards commented on the issue:

          https://github.com/apache/metron/pull/628

          Yes. Another PR was merged into master, and this PR refactored Stellar greatly. This has introduced conflict with your changes ( they made change and you made changes etc ).

          You need to resolve the conflicts and push the result to your github branch

          githubbot ASF GitHub Bot added a comment -

          Github user asfgit closed the pull request at:

          https://github.com/apache/metron/pull/628


            People

            • Assignee:
              ottobackwards Otto Fowler
              Reporter:
              jasperknulst Jasper Knulst
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development