Uploaded image for project: 'Apache MetaModel'
  1. Apache MetaModel
  2. METAMODEL-93

Upgrade HBase dependency to support Hadoop 2

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 4.3.0-incubating
    • Fix Version/s: None
    • Labels:
    • Environment:
      Cloudera CDH 5.1.0

      Description

      Current hbase-client dependency version in HBase module is 0.95.1-hadoop1. We should consider upgrading our depedency to support Hadoop 2.

      I tried to connect to HBase in Cloudera's Quickstart VM with CDH 5.1.0 from MetaModel, but it is using HBase 0.98.1 (Hadoop 2). I guess, many people start with this popular distribution for a proof of concept, so ensuring that MetaModel can connect to HBase on Hadoop 2 is important.

        Attachments

          Activity

            People

            • Assignee:
              tomaszguzialek Tomasz Guziałek
              Reporter:
              tomaszguzialek Tomasz Guziałek
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: