Uploaded image for project: 'Mesos'
  1. Mesos
  2. MESOS-9626

Make SLRP pick the appropriate CSI versions for plugins.

    XMLWordPrintableJSON

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 1.8.0
    • Component/s: storage

      Description

      To detect the CSI version supported by a plugin, we could call v1.Probe, and fallback to v0.Probe if the previous call fails.

      Alternatively, we could introduce a field in CSIPluginInfo to specify the plugin version to use.

        Attachments

          Activity

            People

            • Assignee:
              chhsia0 Chun-Hung Hsiao
              Reporter:
              chhsia0 Chun-Hung Hsiao
              Shepherd:
              Benjamin Bannier
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: