Uploaded image for project: 'Mesos'
  1. Mesos
  2. MESOS-426

Python-based frameworks use old API and are broken

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 0.9.0
    • Fix Version/s: None
    • Component/s: framework, python api
    • Labels:
      None

      Description

      If you try to use mesos-submit or torque with mesos 0.9.0+, you get exceptions due to API mismatches in these framework's expectations of the python API.

      Steps to reproduce: try running "mesos-submit <mymaster> echo hi", note the stacktraces.

        Attachments

        1. mesos_changes.p1
          17 kB
          David Greenberg

          Activity

            People

            • Assignee:
              dgrnbrg David Greenberg
              Reporter:
              dgrnbrg David Greenberg
            • Votes:
              0 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: