Uploaded image for project: 'Maven Enforcer Plugin'
  1. Maven Enforcer Plugin
  2. MENFORCER-93

[maven 3.x] configuration not recognized on <executions> level

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 1.0-beta-1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:
      maven 3.0-alpha-7, enforcer plugin 1.0-beta-1

      Description

      I tried the example snippet from

      http://maven.apache.org/plugins/maven-enforcer-plugin/usage.html

      with enforcer plugin 1.0-beta-1 and maven 3.0-alpha-7.

      It seems the enforcer configuration is only recognized if moved up to the <plugin> level.
      <configuration> under <execution> is ignored. The plugin complains that no rules are configured.

      This may be a general maven 3 bug ...

      See example poms attached for reproducing the problem and an alternative pom with configuration on plugin level which works.

      Also includes

      mvn enforcer:enforce -X -e

      output.

      Regards
      Jan

        Attachments

          Activity

            People

            • Assignee:
              bentmann Benjamin Bentmann
              Reporter:
              jan.sievers Jan Sievers
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: