Uploaded image for project: 'Maven Enforcer Plugin'
  1. Maven Enforcer Plugin
  2. MENFORCER-89

Plugin doesn't validate my current build, but the latest SNAPSHOT in the repository!

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.0-beta-1
    • Fix Version/s: None
    • Component/s: Plugin
    • Labels:
      None

      Description

      I've added the enforcer-plugin to my build today, but now my projects don't build anymore! The reason for that is that the enforcer-plugin is reporting missing versions (<requirePluginVersions />), although the versions are actually set!

      I've been checking what might be wrong and noticed that as soon as the plugin executes, it checks for updates for the project that is currently being built! In that case, the plugin is actually right, because the latest deployed snapshots have some unversioned plugins. However, shouldn't the plugin validate the project currently in the reactor?

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rfscholte Robert Scholte
                Reporter:
                malice Roland Asmann
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: