Uploaded image for project: 'Maven Enforcer Plugin'
  1. Maven Enforcer Plugin
  2. MENFORCER-360

requireUpperBoundDeps should have option to check for same major version

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 3.0.0-M3
    • Fix Version/s: None
    • Component/s: Standard Rules
    • Labels:
      None

      Description

      In our project we use semantic versioning for our dependencies (https://semver.org/)

      The requireUpperBoundDeps rule already checks for compatible versions, but we would like to have the option to specify that no major (i.e. breaking) versions are mixed.

      So a (transitive) dependency on groupId:artifactId:1.0.0 and on groupId:artifactId:2.0.0 means that we have a conflict.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                guyv Guy Veraghtert
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated: