Maven Eclipse Plugin
  1. Maven Eclipse Plugin
  2. MECLIPSE-394

Commandline Arguments do NOT override settings from pom.xml

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.5
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      It was reported on the maven-users mailinglist, that specifying various command line arguments like -DdownloadSources=false -Declipse.wtpmanifest=true -Declipse.wtpapplicationxml=true -Dwtpversion=2.0 has no effect. It turned out, that specifying this in the pom.xml file worked as expected. However, commandline arguments should always override settings from the pom.

        Issue Links

          Activity

          Martin Höller created issue -
          Brad Szabo made changes -
          Field Original Value New Value
          Link This issue is related to MNG-2974 [ MNG-2974 ]
          Michael Osipov made changes -
          Resolution Won't Fix [ 2 ]
          Status Open [ 1 ] Closed [ 6 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 10:00:37 UTC 2015 [ 1428228037919 ]
          Mark Thomas made changes -
          Workflow jira [ 12720795 ] Default workflow, editable Closed status [ 12750699 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 23:47:18 UTC 2015 [ 1428277638729 ]
          Mark Thomas made changes -
          Workflow jira [ 12958182 ] Default workflow, editable Closed status [ 12995074 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Martin Höller
            • Votes:
              4 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development