Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.3
    • Fix Version/s: None
    • Component/s: WTP support
    • Labels:
      None
    • Environment:
      Eclipse 3.2.1 and WTP 1.5.2, JBoss AS 4.0.4.GA, J2EE appliaction comprized of an EJB and Web module, all bundled withing an EAR module.

      Description

      After I modify the EAR project configuration in order to remove problems on the EAR project (the plugin adds the Java project facet and I must modify by hand the org.eclipse.wst.common.project.facet.core.xml file in order the remove it,this should be a separate JIRA I think) my project can get built (no red decorators on the projects). However, I add the server definition and when I try to publish the project I get an error "Could not publish to the server." with the following Exception Stack Trace:

      Error
      Thu Nov 23 20:56:58 CET 2006
      Could not publish to the server.

      org.eclipse.emf.common.util.BasicEList$BasicIndexOutOfBoundsException: index=0, size=0
      at org.eclipse.emf.common.util.BasicEList.get(BasicEList.java:512)
      at org.eclipse.jst.j2ee.componentcore.EnterpriseArtifactEdit.getDeploymentDescriptorRoot(EnterpriseArtifactEdit.java:154)
      at org.eclipse.jst.j2ee.componentcore.util.EARArtifactEdit.getApplication(EARArtifactEdit.java:291)
      at org.eclipse.jst.j2ee.internal.deployables.J2EEFlexProjDeployable.isNestedJ2EEModule(J2EEFlexProjDeployable.java:528)
      at org.eclipse.jst.j2ee.internal.deployables.J2EEFlexProjDeployable.shouldIncludeUtilityComponent(J2EEFlexProjDeployable.java:135)
      at org.eclipse.wst.web.internal.deployables.ComponentDeployable.addUtilMembers(ComponentDeployable.java:347)
      at org.eclipse.jst.j2ee.internal.deployables.J2EEFlexProjDeployable.members(J2EEFlexProjDeployable.java:193)
      at org.eclipse.jst.server.generic.core.internal.publishers.AbstractModuleAssembler.copyModule(AbstractModuleAssembler.java:160)
      at org.eclipse.jst.server.generic.core.internal.publishers.EarModuleAssembler.assemble(EarModuleAssembler.java:36)
      at org.eclipse.jst.server.generic.core.internal.publishers.AntPublisher.assembleModule(AntPublisher.java:124)
      at org.eclipse.jst.server.generic.core.internal.publishers.AntPublisher.publish(AntPublisher.java:109)
      at org.eclipse.jst.server.generic.core.internal.GenericServerBehaviour.publishModule(GenericServerBehaviour.java:91)
      at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModule(ServerBehaviourDelegate.java:676)
      at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publishModules(ServerBehaviourDelegate.java:756)
      at org.eclipse.wst.server.core.model.ServerBehaviourDelegate.publish(ServerBehaviourDelegate.java:611)
      at org.eclipse.wst.server.core.internal.Server.doPublish(Server.java:862)
      at org.eclipse.wst.server.core.internal.Server.publish(Server.java:850)
      at org.eclipse.wst.server.core.internal.PublishServerJob.run(PublishServerJob.java:142)
      at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)

      I don't see people complaining so perhaps it's my fault. Any ideas? If more info is needed please ask.
      I can start the server with no problems and it's on a path with no spaces.
      Thanks Srgjan

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Srdan Srepfler
          • Votes:
            5 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development