Uploaded image for project: 'Maven Deploy Plugin'
  1. Maven Deploy Plugin
  2. MDEPLOY-244

maven deploy plugin 3.0.0-M1 breaks deploys when alt*DeploymentRepository properties are used

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Closed
    • Critical
    • Resolution: Done
    • 3.0.0-M1
    • 3.0.0-M2
    • deploy:deploy-file
    • None

    Description

      After upgrading to maven deploy plugin to 3.0.0-M1, our Maven Builds that uploads an RPM artifact broke.  All other artifacts, like zips, pom, jar, etc.. was able to upload without problems.    But as soon as the build tried to upload an RPM the upload threw an 401 Error:  

       

      [Continue Pipeline] [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:3.0.0-M1:deploy (default-deploy) on project company-fancyname-atg-apptype-ibm-qa4: ArtifactDeployerException: Failed to deploy artifacts: Could not transfer artifact com.sephops.fancyname:company-fancyname-atg-apptype-ibm-qa4:rpm:ProjectName-20181001.061415-35 from/to company-snapshot-yum::default (http://artifactory.com/artifactory/company-snapshot-yum-local): Failed to transfer file: http://artifactory.com/artifactory/company-snapshot-yum-local/com/sephops/fancyname/company-fancyname-atg-apptype-ibm-qa4/ProjectName-SNAPSHOT/company-fancyname-atg-apptype-ibm-qa4-ProjectName-20181001.061415-35.rpm. Return code is: 401, ReasonPhrase: Unauthorized. -> [Help 1]

      Attachments

        1. test-maven-deploy.zip
          12 kB
          William So
        2. project-pom.xml
          1 kB
          Andrew Lillie
        3. root-pom.xml
          6 kB
          Andrew Lillie

        Issue Links

          Activity

            People

              khmarbaise Karl Heinz Marbaise
              william.so William So
              Votes:
              5 Vote for this issue
              Watchers:
              15 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved: