Uploaded image for project: 'Maven Dependency Plugin'
  1. Maven Dependency Plugin
  2. MDEP-380

copy-dependencies should be able to use the artifact's baseVersion

    XMLWordPrintableJSON

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.5.1
    • Fix Version/s: 2.6
    • Component/s: copy-dependencies
    • Labels:
      None
    • Flags:
      Patch

      Description

      It should be possible to copy dependencies with their baseVersion.
      Currently the version used for snapshots is the resolvedVersion (timestamped version) org.apache.maven.artifact.DefaultArtifact.setResolvedVersion(String) which may be the timestamped snapshot version.
      When calling copy-dependencies I expect snapshots to have the snapshot version org.apache.maven.artifact.DefaultArtifact.getBaseVersion().

      The attached patch introduces a new parameter 'useBaseVersion' which, if selected, sets the base version in the copied artifact's names.

        Attachments

        1. maven-dependency-plugin.patch
          8 kB
          Marc Brugger

          Issue Links

            Activity

              People

              • Assignee:
                rfscholte Robert Scholte
                Reporter:
                bakito Marc Brugger
              • Votes:
                3 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: