Uploaded image for project: 'Maven Dependency Plugin'
  1. Maven Dependency Plugin
  2. MDEP-252

Used system properties should be prefixed with e.g. the artifactId ala dependency-plugin.outputFile

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Auto Closed
    • Affects Version/s: 2.1
    • Fix Version/s: None
    • Component/s: tree
    • Labels:
      None

      Description

      I was using dependency:tree and help:effective-pom, both use a system property outputFile to redirect their output to a file and so will override their output.
      IMO dependency-plugin.outputFile would be a better name.

      Best Regards
      Mirko

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              mfriedenhagen Mirko Friedenhagen

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment