• Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.3
    • Labels:


      Deafult source level setting for Maven compiler plugin is 1.3, as far as I remember. This makes no sense. 1.3 is used at this moment only in legacy applications. Probability of porting such legacy application to Maven 2 is very small. I was working with such applications - none of them used Maven. In fact, I don't know any application using Maven, which requires level 1.3.
      On the other hand, Maven is used exensively in new applications. Most of them use Java 5 features (annotations, generics...). All new applications I create use Maven 2 and Java 5. Every time I setup such application it makes me crazy that I get errors on my generics and annoations, and I have to setup manually the source level to 1.5. Come on, we have year 2008, not 2000! Java 5 is here for several years already. So why Maven compiler plugin does not use the most reasonable default approach, instead it still assumes we are in 2000 year? If someone wants to use old java version, than he can change the source level. By default should be 1.5.
      The default setting can be changed in never wersion of maven compiler plugin.


          Issue Links



              • Assignee:
                jvanzyl Jason van Zyl
                grzegorzborkowski Grzegorz Borkowski
              • Votes:
                44 Vote for this issue
                12 Start watching this issue


                • Created: