Uploaded image for project: 'Maven Compiler Plugin'
  1. Maven Compiler Plugin
  2. MCOMPILER-243

Compiler Plugin's Documentation on Compiler Args Seems Wrong

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Trivial
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: None

      Description

      On this page:

      http://maven.apache.org/plugins/maven-compiler-plugin/examples/pass-compiler-arguments.html

      I'm instructed to express compilerArgs this way:

      <plugins>
      <plugin>
      <groupId>org.apache.maven.plugins</groupId>
      <artifactId>maven-compiler-plugin</artifactId>
      <version>3.3</version>
      <compilerArgs>
      <arg>-verbose</arg>
      <arg>-Xlint:all,-options,-path</arg>
      </compilerArgs>
      </plugin>
      </plugins>

      When I do that I get an error:

      Unrecognised tag: 'compilerArgs' (position: START_TAG seen ...</configuration>\n <compilerArgs>... @21:27)

      But when I tuck the compilerArgs XML element under the configuration element, it works:

      <plugin>
      <groupId>org.apache.maven.plugins</groupId>
      <artifactId>maven-compiler-plugin</artifactId>
      <version>3.3</version>
      <configuration>
      <compilerArgs>
      <arg>-verbose</arg>
      <arg>-Xlint:all,-options,-path</arg>
      </compilerArgs>
      <source>1.8</source>
      <target>1.8</target>
      </configuration>
      </plugin>

        Attachments

          Activity

            People

            • Assignee:
              khmarbaise Karl Heinz Marbaise
              Reporter:
              timjstewart Tim Stewart
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: