Maven Compiler Plugin
  1. Maven Compiler Plugin
  2. MCOMPILER-183

Maven on JDK 7 can't compile classes with UTF-8 characters in the name.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.5.1
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Description

      I have created a project on Github that reproduces and explains the exact issue.

      https://github.com/aslakhellesoy/maven-utf8-jdk7-woes

        Activity

        Aslak Hellesøy created issue -
        Aslak Hellesøy added a comment -

        Turns out this is an OS X issue and not a Maven issue. Everything works fine on Linux. I'm closing this.

        Aslak Hellesøy added a comment -

        See updated details of my findings in the Github project.

        Aslak Hellesøy made changes -
        Field Original Value New Value
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 09:20:51 UTC 2015 [ 1428225651644 ]
        Mark Thomas made changes -
        Workflow jira [ 12718692 ] Default workflow, editable Closed status [ 12749991 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 22:48:53 UTC 2015 [ 1428274133206 ]
        Mark Thomas made changes -
        Workflow jira [ 12956080 ] Default workflow, editable Closed status [ 12993100 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        1h 9m 1 Aslak Hellesøy 04/Oct/12 15:47

          People

          • Assignee:
            Unassigned
            Reporter:
            Aslak Hellesøy
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development