Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Not A Problem
    • Affects Version/s: 2.4
    • Fix Version/s: None
    • Component/s: changes.xml
    • Labels:
      None

      Description

      Sorry, i don't get it.
      i try to add/config my own tracking system.

      <issueManagement>
      <system>testtesttest</system>
      <url>http://somehost.com/project/dashboard</url>
      </issueManagement>

      but i cant use the %URL%, i specify this absolute in the plugin section.

      <configuration>
      <issueLinkTemplatePerSystem>
      <testtesttest>http://somehost.com/items?query=%ISSUE%</testtesttest>
      </issueLinkTemplatePerSystem>
      </configuration>

      in my changes.xml, the system is also testtesttest.
      Tried everything, but i dont get links.

      if i use

      <issueLinkTemplate>http://somehost.com/items?query=%ISSUE%</issueLinkTemplate>

      and "default" in changes.xml i DO get links, but always with the default value (regardless whats specified)

      [DEBUG] (f) issueLinkTemplate = %URL%/ViewIssue.jspa?key=%ISSUE%

      if i specify f. ex. "SourceForge" in changes.xml, the links work out-of-the-box

      tried also old suggestions like MCHANGES-166 - no success.

        Attachments

        1. MCHANGES-226.zip
          2 kB
          dennislundberg
        2. MCHANGES-226.zip
          2 kB
          dennislundberg

          Activity

            People

            • Assignee:
              dennisl@apache.org Dennis Lundberg
              Reporter:
              myron Myron
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: